Esphome encja niedostępna

zależy jakiego rodzaju korekcja jest potrzebna

dla DS18B20 to bym się spodziewał konieczności korekcji wielomianowej (funkcja kwadratowa wystarczy do uzyskania “laboratoryjnej” dokładności w sensownie wąskim zakresie temperatur - myślę że spokojnie do ogarnięcia w ten sposób np. od 0 do 50 stopni C), o ile oczywiście dysponujesz jakimś termometrem referencyjnym

Na razie DS-y wykorzystuje do “sterowania” ogrzewaniem podłogowym przy pompie ciepła. Dokładność poniżej 1 stopnia to byłaby przesada. Moje pytanie dotyczyło raczej możliwości przypisania stałego “błędu wskazania” - różnicy pomiędzy wskazaniem DS a właściwą temperaturą pomieszczenia. Wzorcuje sobie DS pirometrem - umieszczam aluminiowa płytkę ( DS sa zabezpieczone w tulejkach alu) na kilka godzin w pomieszczeniu i porównuj wskazania. W Supli można taką tolerancję określić z poziomu urządzenia np: Sonoof-a.
A problem z brakiem komunikacji WIFI z Wemosem wynikał …z konfliktu adresu IP. Cóż…kłania się Brzywa Okhmana.

Podłączę się do tematu. Zacząłem używać od niedawna ESPHome na razie to jest jedno urządzenie. Od tego czasu w logach mam mnóstwo ostrzeżeń i błędów związanych z urządzeniami połączonymi po WIFI. Wydaje mi się, że ma też to wpływ na samo HA zdarza się że nie można otworzyć strony w przeglądarce.

EDIT:
Moje podejrzenia sprawdziły się. Po tym jak dodałem ten wpis wyłączyłem ESPHome i do tej pory mam czyste logi. Ktoś coś podpowie? Mam standardową konfigurację ESPHome.

Zajrzyj pod pierwszego linka - tam masz stałą korekcję z poziomu urządzenia.

Ja bym nie przesadzał, ESP się tym nie zmęczy- jeśli masz możliwość kalibracji w 3 temperaturach (najlepiej początek, środek i koniec zakresu użytkowego) to użyj korekcji za pomocą funkcji kwadratowej - drugi link.
Sugeruję to, bo wiem, że te Dallasy są nieliniowe w dość charakterystyczny sposób, a niedokładność jest rzędu bodajże 1°C w zakresie jaki podałem wcześniej i wynika z samej nieliniowości (pomijam tu stały offset który może dołożyć jeszcze 1°C, a może i więcej jeśli trafiłeś na jakieś egzemplarze o sporej odchyłce - czasem mam wrażenie, że są sprzedawane detalicznie odrzuty produkcyjne).
Oczywiście jeśli nie ma możliwości takiej kalibracji, to link 1. (oba prowadzą do tego samego artykułu w dokumentacji technicznej, tylko do różnych miejsc).

Mam podobny problem z niedostępną encją w ESPHOME ESP32, a czasami moim zdaniem nawet się resetuje, ale tego jeszcze nie sprawdziłem dokładnie. Wykorzystuję ESPHome do sterowania rolet wewnętrznych opartych na silnikach krokowych ( wzorowałem się na tych rozwiązaniach Motor on a roller blind - ESPHome version? - ESPHome - Home Assistant Community). Testowałem jeden zestaw przez kilka miesięcy i nie miałem dużych problemów z tym sterowaniem, ale ostatnio zaczęło się to częściej. Szukałem trochę w sieci i znalazłem kilka wątków i przewijał się niby problem z key_api, ale w moim przypadku nie mam szyfrowania. Autor wątku przeszedł na Tasmotę, ale może ktoś też walczył z podobnym problemem i mu się udało coś rozwiązać w tej kwestii.