Konfiguracja conbee II w Home Assistant

Witam. Być moze odgrzewam temat ale mnie nie udało się nic znaleźć jak skonfigurować i używać conbee II. Posiadam terminal HP T620 a na nim proxmox. I o to moje pytanie: czy podczas konfiguracji conbee podpinam go do laptopa czy do terinala? Z goty dziekuje za odp.

Mam tak samo, tzn.

Terminal z proxmoxem, tutaj mam podpiętego ConBee2.
ProxMox ma wybrane urządzenie USB i przypięte do wirtualki z HomeAssistantem - dziękitemu HA myśli i widzi urządzenie USB wpięte do siebie.

image

w HA Settings > system > hardware > all hardware
wpisujesz conbee, otwierasz parametry i kopiujesz ID urządzenia, o to:

instalacja MQTT, dodatku Zigbee2Mqtt w moim przypadku więc tutaj podpowiem koją konfigurację gdzie jako port wkleiłem moje ID mojego cb2.

data_path: /config/zigbee2mqtt
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
mqtt:
  server: mqtt://core-mosquitto:1883
  user: mqtt-user
  password: ***********************
serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2674839-if00
  adapter: deconz
zigbee_herdsman_debug: true
1 Like

Dzięki za odp. Wszystko zdrozumiałe do momentu pkt 3. I nasuwa sie kolejne pytanie o jaka instalecje MQTT i dodatek Zigbee2MGtt chodzi? Czy tez musze zrobic taka instalcje i dodac ten dodatek? Wiem ze dla niektórych to glupie pytanie ale jestem amatorem.

Też jestem początkujący ale pooglądałem filmów na YT zanim coś robiłem.
Wiem że Conbee2 to kontroler zigbee i gdy już jest widoczny w “All Devices” dla HA to masz wybór kilku znanych softów obsługujących kontroler Conbee2. Na YT masz różne ich porównania.

ZHA - wbudowane w HA
Zigbee2Mqtt - prawie wszyscy go mają bo można wiele
deCONZ - do twórców conbee… ale ponoć nie wszystkie urządzenia wykrywa.

Teraz jesteś na etapie gdzie każdy toturial z YT zadziała.

ok. Jeszcze raz dzieki za odp

Witam ponownie. I znowu problemy. Podlaczony do terminala conbee. W proxmox udostepniony port usb Add → USB Device → Use USB Vendor/Device ID-> ConBee. Niestety nie pokazuje mi sie ttyACM0 w czym jest znowu problem?

Edit:

sam sobie odp. Trzeba bylo zrobic restart terminala :slight_smile: Ale i tak jest ptoblem
[18:04:25] INFO: Preparing to start…
[18:04:26] INFO: Socat not enabled
[18:04:29] INFO: Starting Zigbee2MQTT…
Zigbee2MQTT:info 2023-10-06 18:04:38: Logging to console and directory: ‘/config/zigbee2mqtt/log/2023-10-06.18-04-38’ filename: log.txt
Zigbee2MQTT:info 2023-10-06 18:04:38: Starting Zigbee2MQTT version 1.33.1 (commit #unknown)
Zigbee2MQTT:info 2023-10-06 18:04:38: Starting zigbee-herdsman (0.19.0)
Zigbee2MQTT:error 2023-10-06 18:04:49: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2023-10-06 18:04:49: Failed to start zigbee
Zigbee2MQTT:error 2023-10-06 18:04:49: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2023-10-06 18:04:49: Exiting…
Zigbee2MQTT:error 2023-10-06 18:04:49: undefined

konfiguracja u mnie wyglada tak

enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: "-d -d"
log: false

serial
port: /dev/ttyACM0
adapter: deconz

port: /dev/ttyACM0

Zmień na by-id tak jak pokazał SiBex, wtedy USB będzie rozpoznawane przez ID

niestety to samo. Ja mam ttyACM0 i ttyACM1

port: >-
/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2672117-if00
adapter: deconz

Moja cała konfiguracji Zigbee2MQTT

data_path: /config/zigbee2mqtt
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8486,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: true
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://core-mosquitto
  user: mqtt
  password: mqtt
serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2124565-if00
  adapter: deconz
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
advanced:
  log_level: warn
  pan_id: 6754
  channel: 11
  network_key:
    - 1
    - 3
    - 5
    - 7
    - 9
    - 11
    - 13
    - 15
    - 0
    - 2
    - 4
    - 6
    - 8
    - 10
    - 12
    - 13
  availability_blocklist: []
  availability_passlist: []
  elapsed: true
  last_seen: ISO_8601_local
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
  port: 8099
experimental: {}
availability: false

Podmień user: xxx, password: xxxx i ConBee
Oczywiście podłączyłem ConBee przez przedłużacz USB (zakłócenia)
/
Dodaj nowego użytkownika Ustawienia > Osoby > Użytkownicy np.
user: mqtt
password: mqtt

a możesz pokazać co masz w All Hardware, tak jak na obrazku w tamtym poście?

możesz zrobić podobnego screenshota?

skad wziac user i password? i ConBee? Tez mam podlaczony 2 m przedłużaczem

Edit:

Ścieżka urządzenia: /dev/ttyACM0

Identyfikator: /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2672117-if00

no i właśnie zamiast tego
/dev/ttyACM0

masz mieć

serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2672117-if00

to jest użytkownik i jego hasło, których stworzyłeś w konfiguracji swojego brokera MQTT (ale NIE chodzi o dane użyte w integracji MQTT z HA!)

Jeśli masz broker Mosquitto w postaci Dodatku, a twoja instalacja HA to tak naprawdę jest HAOS (lub supervised), to (tylko w przypadku spełnienia obu tych warunków) wystarczy, że założysz sobie (w trybie zaawansowanym, czyli Ustawienia → Osoby → Użytkownicy → Dodaj Uzytkownika) zwykłego (bez praw administratora) użytkownika mqtt z hasłem mqtt a Dodatek Mosquitto sobie go wykorzysta (oczywiście należy zrestartować HA oraz rzeczony Dodatek, czyli najlepiej cała maszynę wirtualną).

W przypadku gdybyś nie spełniał obu warunków powyżej (HAOS/supervised oraz instalacje kontenerów w postaci Dodatków), to musiałbyś konfigurować wszystko w sposób jawny, bo wtedy nie istnieje konfiguracja domyślna.

i tak tez było i niestety to samo ustawienia dodatki Zigbee2MQTT i w serial wpisane

port: >-
  /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2672117-if00
adapter: deconz

Edit:

ty masz w mqtt

mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://core-mosquitto
  user: mqtt
  password: mqtt

ja nie mam nic czy to poprawne?

Ja tu nie pokazywałem swojej konfiguracji, daj mi skończyć edytować posta, nie mam też Conbee2, ale zasady konfiguracji są dość uniwersalne.

Możesz mieć pusto, daj mi skończyć pisać wyżej, to może to skumasz
w trybie YAML ta pustka wygląda tak

mqtt: {}

Nauki ciąg dalszy - by wkleić kawałek kodu tak, by zachować poprawne formatowanie (bez tego forum rozwali YAMLa)
użyj linijek z trzema odwrotnymi apostrofami (to te dziwne apostrofy spod “klawisza tyldy”) przed i za wklejonym fragmentem kodu.

PS tak swoją, to edytuj swoje posty (w sensie: jeśli post jest ostatni w wątku, to go uzupełniaj, a NIE PISZ następnych WŁASNYCH postów POD SPODEM), czyli nie napieprzaj postami jeden za drugim, bo są tu wyczuleni na takie działania moderatorzy i pewnie polecą ostrzeżenia.

Dzieki za odpowiedz kolejna lekcje. Moze powinienem wgrac nowy soft.

Rozwiązanie: U mnie konfiguracja była prosciejsza bez kombinowania: tryb Yaml

data_path: /config/zigbee2mqtt
socat:
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: false
mqtt: {}
serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2672117-if00
  adapter: deconz
1 Like

2 posty zostały podzielonye na nowy temat: Zigbee2MQTT przestało działać

Co tu się odstawia?
gdzie jest post z rozwiązaniem wątku, bo z pewnością nie jest to ten z pytaniem?
Tj. z jakiej paki zaznaczony jako rozwiązanie jest post zawierający treści nieszczególnie związane z pierwszym postem, a już na pewno nie jest to rozwiązanie,
kto tu taki burdel stworzył?

edit: aha już widzę, dzięki @rafkan
zaczniemy od nowa zamykam ten wątek, bo to nie ma sensu