Naliczanie kWh przestaje działać po dodaniu kosztów

sensor:
  - platform: integration
    source: sensor.zuzycie_pradu
    name: energy_serverroom
    method: left
    unit_prefix: k
    round: 2

utility_meter:
  daily_energy_serverroom:
    source: sensor.energy_serverroom
    cycle: daily

  monthly_energy_serverroom:
    source: sensor.energy_serverroom
    cycle: monthly

sensor:
   - platform: template
     sensors:
      monthly_boiler_pln:
        friendly_name: "Koszt miesięczny - Boiler"
        unit_of_measurement: 'PLN'
        icon_template: mdi:currency-eur
        value_template: "{{ (states('sensor.monthly_energy_serverroom')|float(0) * 0.82)|round(2) }}"
      daily_boiler_pln:
        friendly_name: "Koszt dzienny - Boiler"
        unit_of_measurement: 'PLN'
        icon_template: mdi:currency-eur
        value_template: "{{ (states('sensor.daily_energy_serverroom')|float(0) * 0.82)|round(2) }}"

Co tu robię źle? Gdy jest tylko kWh + utility meter wtedy wszystko działa dobrze ale po dodaniu przeliczania kWh na hajs to już przestaje liczyć kWh i tym samym też nie liczy kosztów.
ps. “sensor.zuzycie_pradu” działa cały czas dobrze, w sensie gdy Boiler się włącza to pokazuje akutalne zużycie

usuń jedną linię sensor:
sprawdź ile spacji przed - platform bo na oczko coś się różni

1 Like
sensor:
  - platform: integration
    source: sensor.zuzycie_pradu
    name: energy_serverroom
    method: left
    unit_prefix: k
    round: 2
  - platform: template
    sensors:
      monthly_boiler_pln:
        friendly_name: "Koszt miesięczny - Boiler"
        unit_of_measurement: 'PLN'
        icon_template: mdi:currency-eur
        value_template: "{{ (states('sensor.monthly_energy_serverroom')|float(0) * 0.82)|round(2) }}"
      daily_boiler_pln:
        friendly_name: "Koszt dzienny - Boiler"
        unit_of_measurement: 'PLN'
        icon_template: mdi:currency-eur
        value_template: "{{ (states('sensor.daily_energy_serverroom')|float(0) * 0.82)|round(2) }}"

Jeśli tak to ma być to wywala błąd.

Edit: Sensors cofnięte o 1 spację i ruszyło. Czy będzie naliczać to się dowiem niebawem.
Edit2: Wszystko teraz działa, dzięki!