Gniazdka Shelly - pogarszający się zasięg wifi

Witam,

od mniej więcej roku korzystam z kilku gniazd Shelly Plug. Od kliku tygodni część z nich zaczęła przejawiać problemy z zasięgiem wifi choć początkowo wszystkie miały max. Do tego stopnia, że HA czasem zgłasza błąd odczytu parametrów z gniazdka. Sytuacja jest o tyle dziwna, że najstarsze gniazdo ma cały czas max poziom sygnału, pomimo bardzo zbliżonej lokalizacji do pozostałych czyli w linii prostej jakieś 5-6m od AP (Ubiquiti UAP) przez jedną cienką ścianę z otwartymi drzwiami. Obok AP mam router z wifi (Funbox) i sytuacja jest analogiczna czyli wykluczam problem z mocą AP.
Czy ktoś zaobserwował u siebie podobne problemy?

Jest to prawdopodobne jako skutek szybkiego starzenia kiepsko zaprojektowanej lub wykonanej elektroniki, masz długookresowy wykres RSSI?

Możesz porównać z moim (u mnie żaden problem nie występuje, jako odniesienie czujniki BLE, gdzie widać nieskorelowane fluktuacje sygnału, poza sporym wzrostem gdy zmieniłem dongla BT)

Nie mam żadnej historii sygnału :-(.
Jak dodałeś sensor RSSI dla Shelly? Moje urządzenia nie raportują tego na integracji natywnej.

Musisz go aktywować - standardowo jest nieaktywny:

rssi

Sądzę, że raportuje, tylko defaultowo ten sensor jest wyłączony, a grunt to z góry wiedzieć o nadchodzących problemach, więc takie rzeczy zwykle odpalam od czasów gdy opcje diagnostyczne w HA defaultowo są wyłączone
(tu dodatkowo mam to wszystko offline, bo shelly odłączone)

Już sobie włączyłem ten sensor, dziękuję za podpowiedź. Pomimo zbliżonej odległości od AP, a nawet to gniazdko ze słabszym sygnałem ma w linii prostej ciut bliżej, różnice są w okolicy 20dBm

obraz

Co ciekawe gniazda NAS i Klimatyzator są obok siebie a różnica w poziomie sygnału jest bardzo duża.

Wiesz, no szklanej kuli to nie mam, by zgadnąć realną przyczynę, ale dam Ci przykład - metalowa pralka czy lodówka jest “ścianą niemal nie do przebicia” dla sygnału radiowego, więc to nie odległość, a przeszkody są najistotniejsze przy doborze miejsc instalacji sprzętu bezprzewodowego wewnątrz typowych mieszkań czy domów.

Nie chodzi o zgadywanie, chodziło mi raczej o ustalenie czy ktoś jeszcze doświadczył spadku czułości gniazdek Shelly. Kiedy je montowałem jakiś rok temu wszystkie miały maksymalny zasięg, przynajmniej według wskaźnika w ich webinterfejsie. Dziś gniazdo lodówki ma tylko jedną kreskę. Warunki przeszkodowe są dokładnie takie jak były, AP jest w tym samym miejscu co był. Jedyna zmienna to zakłócenia, których jak sądzę jest więcej niż rok temu bo widzę więcej sieci sąsiadów.

Bez historii statystyk nie da się tego stwierdzić, fluktuacje sygnału są zawsze możliwe, ale na podstawie pojedynczego sprawdzenia nie wiesz co się naprawdę dzieje.

W kwestii starzenia się sprzętu - zdarza się - akurat smartpluga shelly mam tylko jednego.

No nic, w wolnej chwili zamienię miejscami gniazda i sprawdzę czy to faktycznie kwestia różnej czułości czy jednak poziom sygnału w tych miejscach się pogorszył.

Nie miałem czasu dokończyć posta, bo robota mnie zawaliła, ale właśnie miałem sugerować podmiankę :smiley: (nie ma lepszej metody).

Oprócz tego sugeruję się wyposażyć w jakiś programowy skaner sieci WiFi (np. dla Windowsa mój ulubieniec to InSSIDer 3.1.2.1 (chociaż są jakieś współcześniejsze wersje), a dla Androida i na amazonowe wynalazki

Co do konfiguracji AP to zalecam statyczny wybór kanału (zwykle najsensowniej ustawić 20MHz ewentualnie auto-szerokość i jeden z 1, 6 lub 11).

Jaki by to nie był skaner, nie pokaże on zakłóceń pochodzących z innych źródeł niż sąsiednie sieci (niestety aby zobaczyć co się dzieje naprawdę potrzebny jest prawdziwy analizator widma, a nie wykorzystywanie zupełnie podstawowych możliwości jakie daje karta WiFi).

A co do samego starzenia - jak dotąd tego rodzaju problem widziałem w przypadku AP i routerów - zwykle pomagała wymiana zasilacza na sprawny lub przelutowanie kondensatorów elektrolitycznych w torze zasilania), ale nie da się wykluczyć podobnych objawów w przypadku dowolnych innych urządzeń z WiFi na pokładzie.

Ja jestem bardzo rozczarowany urządzeniami Shelly. Konkretnie przełącznikiem Shelly1. Co jakiś czas jest raportowania niedostępność. Jeśli w czasie niedostępności jest przekazana jakaś komenda to często urządzenie się zawiesza. Wtedy pomaga jedynie odłączenie prądu. Już dwa razy w takiej sytuacji nastąpiło trwałe zawieszenie i konieczna była reklamacja gwarancyjna. Reasumując dla jednego punktu w przeciągu 2 miesięcy już były 2 wymiany dla trwałego zawieszenia, dwa razy dodatkowo odsyłałem z powodu zawieszeń. Masakra

Nie jestem wsparciem producenta, ale w przypadku integracji z HA po api mam takie ustawienia w Shelly (pomijam konfigurację sieci, bo ona musi odpowiadać temu co masz dostępne w swojej sieci, a np. przynajmniej w “Plug S” jest możliwe m.in. ustawienie backupowego AP jeśli masz sieć WiFi, która nie działa stabilnie) - bez chmury, bez MQTT, z włączonym ColoT, z polską pulą serwerów czasu (jeśli twoja sieć bywa offline to sugeruję zamiast tego użyć addon chrony i skorzystać z lokalnego serwera czasu) i działa 100% stabilnie (od ponad roku).

To jest raczej temat dla wsparcia producenta, bo działając dalej w ten sposób (bez zdiagnozowania przyczyny, a likwidując jedynie skutki) będziesz wymieniał sprzęt w nieskończoność (a jak przypuszczam sprzedawca nie dysponuje wystarczającą wiedzą skoro sprowadza temat do wymiany sprzętu).

Ciekaw jestem co to znaczy “trwale zawieszenie” - masz na myśli sytuację, gdy pozornie wszystko działa poprawnie, a przekaźnik jest na stałe włączony?

Mam u siebie w domu 43 urządzenia shelly1 i 5 shelly2.5.
Też zauważyłem utraty połączenia z SSID, jednak maksymalnie w ciągu 15min smoczynnie przywraca się połączenie i jest to dość sporadyczne. Nigdy nie miałem trwałych zawieszeń i ogólnie jestem zadowolony z tego produktu.