Gniazdko Hykker SE-0792

W związku z świętami i mnogością lampek wyciągnąłem z szuflady gniazdko z Biedronki
Niestety próba fleshowania przez tuyaconvert się nie udaje.
Z apką SmartLife łączy się bez problemu wersja modułu głównego: V1.1.7 wersja modułu MCU: V1.1.7
Czy da się to jakoś jeszcze ogarnąć bez otwierania?


To nie jest SmartDGM PP-W162 - stworzę osobny wątek, skąd wiesz co jest w środku, skoro nie otwierałeś?

No to “młotek i przecinak” poszedł w ruch :grin: w środku mam coś takiego


Wygląda zwyczajnie - alternatywny soft na tym poleci, nie widać jak nazywa się płytka zawierająca ESP8266EX
mi wygląda na ten moduł
https://tasmota.github.io/docs/Pinouts/#tylc4

Jak rozszyfrujesz modeł płyty głównej (na 2 zdjęciu zasłania go żółtozielony kabel) to może znajdziesz gotowca dla tego gniazdka.

Kabelek przesunięty
MODEL: ZJ-J16B
REV:1.1 20190806

Nie ważne - wystarczyło poszukać po modelu :stuck_out_tongue:

Konfigurację znalazłem problem jest w tuyaconvert .
Tak po prostu się powtarza w kółko:

....................................
SmartConfig complete
Resending SmartConfig Packets

po kliku próbach

Timed out while for the device to (re)connect

Masz sprzęt otwarty - użyj kabelka - to jest zawsze skuteczne.

Metody opierające się na OTA wykorzystują luki w fabrycznym firmware, więc czasem wystarczy podpiąć sprzęt pod oficjalną apkę aby soft został zaktualizowany i załatany (a tym samym niepodatny na nieoficjalne OTA).
Oczywiście zakładam, że wykonałeś wszystkie wymagane kroki i się nie udało.

Czytałem o łataniu softu więc to pewnie to, ale z kabelkami sobie odpuszczę nie ten wzrok i i mam chyba za duży grot w lutownicy na takie mikro lutowanie, a i lutowniczy zemnie marny :slight_smile:

Prawdopodobnie chcesz lutować w innym miejscu niż jest to realnie potrzebne.

Ale nawet gdybym nie miał racji i jedyne dostępne punkty były na samym ESP, to jednak przy odrobinie determinacji do flashowania ogarniesz to klamerkami do prania i paroma drucianymi przewodami wyszarpanymi z biednej skrętki instalacyjnej (bez lutowania, byleby był skuteczny styk).

TYLC4 ma już w miarę normalnej wielkości wyprowadzenia - musisz tylko sprawdzić czy są tam wszystkie sygnały potrzebne do flashowania.

1 Like

Masz rację patrzałem nie w to miejsce. Po wyjęciu płytki wygląda to inaczej, ale nie mam pojęcia jak składają to małe Chińs… rączki. Po wyjęciu wypadły dwa plasticzki doszedłem skąd ale bez kleju przy składaniu się nie obędzie. Jeśli chodzi o klamerki to ten numer chyba nie przejdzie będę lutował :nerd_face:

Edit:
Znalazłem prawie klona Hykkera Flashing Tasmota on Smart Plugs via Serial (sylvainzimmer.com) sprawdzę czy piny też są zgodne z tym opisem i spróbuje zrobić flash.

Nie mam tego w ręce (ani jednego, ani drugiego), więc sam jesteś najlepiej zorientowany w kwestii podobieństw i różnic.

Nie wiem czy to klon czy nie (raczej na 99% nie, bo tamten to na 100% wypust producenta Hysiry - świadczy o tym napis na płycie głównej HYS-01-028… a realnego producenta twojego sprzętu z biedry nie udało mi się rozpoznać), ale to nie ma znaczenia - Tuya produkuje skończoną ilość modeli swoich modułów - jeśli dobrze rozpoznałem twój bazuje na TYLC4 i tamten pewnie też?
Jeśli tak, to miejsca podpięcia do UARTa (i zasilania) będą te same - bo flaszujesz tylko moduł SoC (reszta “flaków” może być inaczej podpięta, więc użyj template dedykowane dla konkretnie tego Hykkera).

Generalnie Tasmota i zbliżone projekty rozwijają się tak szybko, że tutoriale w kwestii oprogramowania mogą być przestarzałe - weź na to poprawkę i poczytaj najlepiej oficjalną dokumentację projektu.

Można spróbować “wydzwonić” piny złącza lutowanego moduły do pinów ESP8266.
W ten sposób można ograniczyć zakres poszukiwań. Dwa pewniaki to Vcc i Gnd.
Dowiesz się w ten sposób czy TxD i RxD są wyprowadzone na złącze.
GPIO, od przycisku również łatwo w ten sposób namierzyć.
Jeśli gniazdko jest bez pomiaru mocy to pozostały: Led WIFI i przekaźnik.
Nawet przy szablonie “generic” jesteś w stanie skonfigurować Tasmotę.
Led WIFI i przekaźnik przypisujesz losowo do zidentyfikowanych GPIO, gdy nie działa zamieniasz tylko te dwa ze sobą.
Ile masz tych pinów na złączu?