Gniazdko NEO Coolcam NAS-WR01W 15A

Następne gniazdko WiFi z pomiarem zużycia prądu to NEO Coolcam NAS-WR01W. Dla zainteresowanych wgraniem tasmoty poniżej podaje podstawowe informacje:
Template:

{"NAME":"Neo Coolcam 16","GPIO":[17,0,0,0,134,132,0,0,131,56,21,0,0],"FLAG":0,"BASE":49}

Strona projektu NAS-WR01W 15A oraz oraz zdjęcie przedmiotowego gniazdka:

Dla porównania poniżej zdjęcie trzech gniazdek tj. BlitzWolf SHP6, Neo Coolcam i Gosund SP111

Ciekawe które jest klonem którego.

Na koniec dodam, że gniazdko NEO kupiłem za 32 zł z tej aukcji Ali

1 Like

Ja też dawno temu kupiłem tego NEO (nie wiem czy to jest ta sama wersja) i też chyba za dwadzieścia parę złotych. Muszę się zabrać za te gniazdka, bo gosund też mi przyszły.

@rafkan czy Ty wgrywałeś tasmote do tych gniazdek przez tuya-convert? Nie mogę się z nimi połączyć przez Tuya-convert.

@pawelwaz tak przez tuyaconvert - poszło bez problemu.

Próbuję różnych sposobów parowania, ale nie wychodzi

Wszystkie są klonami… Fibaro (w sensie zerżnięcia pomysłu na upchnięcie elektroniki w obudowie takiego kształtu).
Neo-coolcam (wtedy się nazywali nieco inaczej) raczej był pierwszy po Fibaro (i w tej obudowie pierwotnie była produkowana wersja z-wave) nawet wizuale mieli wtedy kradzione z Polski…
Gosund i Blitz są produkowane przez Hysiry (w miarę od niedawna, bo bazują na technologii Tuya).

Kupiłem 4 takie gniazdka - 2 szt 16A i 2 szt 10A i UWAGA - tych 10A nie udało mi się w żaden sposób sflaszować - ani przez wifi ani przez kabelki.
Na początku próbowałem wszystkie przez wifi i na 3 z 4 dostałem komunikat że firmware jest zbyt nowy i nie będzie upgrade. Więc wszystkie rozebrałem i tylko te 16A udało mi się przeprogramować. Sprzętowo te 16A i 10A są zupełnie inne, również rozmieszczenie pinów jest inne, w całym internecie nie znalazłem zdjęcia z podobną płytką więc nie polecam tego modelu - stófka poszła w piach :frowning:

Mam tez pytanie - próbuję wciągnąć te dwie działające sztuki do HA i :

gniazdo wysyła grzecznie komunikaty np takie:

18:35:27 MQT: Connected
18:35:27 MQT: tele/tasmota_0ACB84/LWT = Online (retained)
18:35:27 MQT: cmnd/tasmota_0ACB84/POWER = 
18:35:27 MQT: tele/tasmota_0ACB84/INFO1 = {"Module":"Socket-    1","Version":"9.2.0(lite)","FallbackTopic":"cmnd/DVES_0ACB84_fb/","GroupTopic":"cmnd/tasmotas/"}
18:35:27 MQT: tele/tasmota_0ACB84/INFO2 = {"WebServerMode":"Admin","Hostname":"tasmota_0ACB84-2948","IPAddress":"192.168.1.203"}
18:35:27 MQT: tele/tasmota_0ACB84/INFO3 = {"RestartReason":"Power On"}
18:35:27 MQT: stat/tasmota_0ACB84/RESULT = {"POWER":"OFF"}
18:35:27 MQT: stat/tasmota_0ACB84/POWER = OFF

a HA odbiera co trzeba np tak:

1617814114: New client connected from 192.168.1.203 as DVES_0ACB84 (p2, c1, k30, u'mqtt').

i tu utkwiłem bo nie wiem co teraz powinienem zrobić - chyba dodać go w edytorze plików??? Gdyby ktoś coś mógł pomóc…

pozdrawiam

aaaa i jeszcze dodam że eksperymentalnie zarzuciłem do jednego z nich bina z esphome z tąd - https://community.home-assistant.io/t/neo-coolcam-smart-plug-with-power-monitor/138638 i okazało się że gniazdko zaczęło żyć własnym życiem - samo załączało i gasiło się kiedy chciało, a zwłoka przy manualnym włączaniu była kilkunastosenkundowa (przez mqtt??)

Nie napisałeś z jakiej wersji tasmoty korzystasz, jeśli wyższej niż 9.2 to skorzystaj z natywnej integracji.

To nie te czasy żeby grzebać w pliku konfiguracyjnym. Jeżeli w console Tasmota wpiszesz: SetOption19 1, to włączysz autowykrywanie i gniazdko pojawi się w HA.

Tasmota 9.2.0 by Theo Arends

autowykrywanie włączyłem już wcześniej i bezsukcesu - integracja pusta :frowning_face:

Screenshot_2021-04-07 Konfiguracja - Home Assistant

To dla testu wyłącz autowykrywanie

SetOption19 0

i dodaj ponownie integrację tasmoty

kicha, bez zmian :frowning:

czy ten prefix w konfiguracji jest jakos przypasowany do konfiguracji urządzeń ??
tasmota/discovery

tak czy siak nic nie widać

Osobiście nie korzystam z tej integracji, u mnie tasmota 8.5.1 ma wszystko czego potrzebuje.
Tutaj dość przystępnie autor opisuje konfigurację natywnej integracji tasmoty.

SetOption19 dotyczy automatycznego wykrywania przez MQTT, oczywiście w integracji MQTT też musi być włączona opcja autowykrywania. Przeczytaj także Tasmota w WEMOS - MQTT nie widzi/wyświetla - #4 przez macek

Ok, temat częściowo ogarniety - zrobiłem downgrade oprogramowania do wersji 8.5.1 i wszytko magicznie się pokazało w integracji mqtt. Muszę jeszcze popracować nad pomiarami prądu których na razie brak

Wrzuć zdjęcie wnętrza w przybliżeniu tych 10A.

@jrkmjd tylko pamiętaj, że 8.5.1 wymaga włączenia SetOption19.

co znaczy brak, nie wyświetlają Ci się w menu tasmoty?