Nagły brak zapisu stanu encji do bazy

Witam, jestem tu nowy.
Od razu przechodzę do rzeczy.
Mam HA na RP4, do tego influxdb i grafana.
W tym plugin TrackMap do śledzenia młodocianej.
I nagle, z dnia na dzień plugin mi przestał wyświetlać ślad telefonu córki. Sprawdziłem wszystko i wygląda to tak:

  • w telefonie nic się nie zmieniło, geolokalizacja włączona, apka działa w tle, wysyła lokalizację (mam wykupioną chmurę Nabu Casa).
  • w HA na mapie widzę pozycję tego telefonu
  • w opcjach encji widzę historię z parametrami geolokalizacji,
  • lecz w bazie influxdb nie ma od tego dnia danych… urwało się.

Nie mam pojęcia o co chodzi, wyłączałem i włączałem encję - nic to nie pomaga.
Pomocy.

Czy ta pozycja się zmienia ?

Czyli od jakiego dnia ? Robiłeś jakąś aktualizacje?

Pozycja się zmienia, jest aktualna i właściwa.

Szczerze nie pamiętam co tego dnia się zmieniło… nic nie kojarzę takiego.
Nie rozumiem, czemu mam historię tej lokalizacji w HA ale nie mam danych w bazie.

Ostatnio jest dużo zmian w obszarze Recorder HA, dodatków i aktualizacji.
Sprawdź czy te dane docierają z HA do bazy influxdb, czy grafana otrzymuje te dane ?
Czy posiadasz inne encje w grafanie i czy one są prawidłowo odczytywane .

@Glaca
A jaką bazę HA masz ?

recorder:
  db_url: !secret mariadb_url
  purge_keep_days: 5
  exclude:
    domains:
      - weblink
      - updater
      - input_boolean
      - input_number
      - input_select
      - input_text
      - light
      - media_player
      - sun
      - timer
      - weather

Mam wiele encji i nie zauważyłem, żeby którakolwiek inna się nie zapisywała w bazie.
Lokalizacja mojego telefonu normalnie nadal jest zapisywana, kiedy córki zapis nagle 22-go się urwał.
Da się jakoś “podejrzeć” tą bazę inaczej niż przez kwerendę? Ewentualnie czy można zerknąć w konfigurację encji w kwestii tego czy się zapisują do bazy? Nie wiem czy wypisuję głupoty bo aż tak się na tym nie znam… Najbardziej nie mogę zrozumieć, czemu w historii HA ta lokalizacja ciągle się zapisuje a do bazy influxdb nie trafiają już żadne dane z tej encji od 22-go kwietnia (nie kojarzę co robiłem tego dnia z HA).

Próbowałem dodać wpis “include” do configuration.yaml ale efekt był taki, że wtedy żadna encja nie zapisywała się w bazie a ta, o którą mi chodzi (geocoded.location)… też nie :smiley: :stuck_out_tongue:

EDIT:
Dodam co nowego ustaliłem bo trochę zgłupiałem.
Wylogowałem się na tel. córki, zalogowałem się od nowa podając inną nazwę urządzenia.
Pojawiła się nowa encja geocoded.location dla tego urządzenia, pojawiła się w historii poprawna lokalizacja a w bazie danych… nadal brak jakichkolwiek wartości!!! Pusty rekord.