Node-RED Odczyt z czujników

Cześć.
Mam problem z obsługą ‘entity’, mianowicie nie mogę doinstalować potrzebnych składników, zgodnie z instrukcją GitHub - zachowj/hass-node-red: Companion Component for node-red-contrib-home-assistant-websocket to help integrate Node-RED with Home Assistant Core
Wszystko robię po kolei, jak w instrukcji, resetuje itd, ale nadal w node-red pojawia mi się komunikat

**Attention:** This node requires [Node-RED custom integration ](https://github.com/zachowj/hass-node-red) to be installed in Home Assistant for it to function.

Pozostałe składniki Node-red działają

HA, Proxmox na Dell Wyse

Wczoraj instalowałem przez HACS. Reset HA i Node Red i działa. Aaaa i nie zapomnij o tym punkcie w konfiguracji HA:

  1. In the HA UI go to “Configuration” → “Integrations” click “+” and search for “Node-RED”

Dzięki. Dobrze rozumiem, ze po tym jak znajdę nodered w hacs przez „+” to mam ten dodatek zainstalować?
Niby robiłem tak, ale rezultat kiepski.
Reset nodered nie robi się przy resecie ha?

Jeżeli chodzi o
Companion Component for node-red-contrib-home-assistant-websocket to help integrate Node-RED with Home Assistant Core
To restart HA wystarczy. Jezeli masz jakies problemy z komunikacja HA <-> NR to zrestartuj NR z poziomu supervisor

@gabar5 dokładnie tak, w HACS jak znajdziesz ten dodatek, to go instalujesz. Sam doda wszystkie katalogi i pliki. Po wszystkim musisz jeszcze wejść w konfiguracje → integracje kliknąć w + i poszukać node-red i dodać. Reset HA i powinno działać.

Reset node red nie robi sie z automatu przy resecie HA, to osobne instancje.

Napiszę po kolei, co robię może czegoś nie rozumiem

  1. kopiuje pliki hass-node-red/custom_components/nodered at main · zachowj/hass-node-red · GitHub do folderu custom_components/nodered przez sambę
  2. reset HA
  3. Instaluje NR przez HACS
  4. Reset HA
    Tak powinno być?

Robisz niepotrzebnie dwa razy to samo raz ręcznie potem to samo przez HACS.
Odinstaluj wszystko, usuń folder nodered z custom_components, zrestartuj HA i zainstaluj nodered z HACS

No to jeszcze raz.
Odinstalowałem NR przez HACS, pliki też się usunęły, nie było katalogu nodered. Uruchomiłem ponownie HA. Przez HACS zainstalowałem Nodered, reset HA, reset NR. No i d**a.

**Attention:** This node requires [Node-RED custom integration ](https://github.com/zachowj/hass-node-red) to be installed in Home Assistant for it to function.

artpc, Wkleiłeś zdjęcie z integracji, a nie z HACS. W integracjach też trzeba przeinstalować? Bo już mam mętlik w głowie.

:slight_smile: W integracji dodajesz nodered


W opcjach zaznaczasz dodawanie nowych encji Screenshot - 22.03.2021 , 20_48_21

Screenshot - 22.03.2021 , 20_48_31

Edit.
Reset nodered i działa! Huuura
Dziękuję panowe za wyrozumiałość :wink:

Teraz mam tak i po resecie HA, nadal nie działa. Pewnie jakiś głupi błąd popełniam…

Co ci nie działa? Co chcesz odczytywać z NR ?

artpc Już jest wszystko OK, dzięki