Obsługa kodów RF w OpenMqttGateway

Witam serdecznie
Jestem początkującym użytkownikiem Home Assistanta więc wybaczcie jeśli moje pytania wydadzą się głupie.
Wykonałem sobie mostek RF i zintegrowałem go z home assistantem.
Mostek prawidłowo odczytuje kody z różnych urządzeń ale nie mam zielonego pojęcia co z tym dalej zrobić.
Np. czujnik otwarcia okna wysyła osobno kod otwarcia i kod zamknięcia tylko jak dodać w home assistancie ten czujnik jako urządzenie?
To jest oczywiście najprostszy czujnik ale schody rozpoczną się w momencie próby stworzenia np. obsługi pilota który wysyła już kilkadziesiąt kodów.
Czy istnieje jakiś konfigurator urządzeń gdzie np ustawiam go jako sensor i podaję 2 kody, lub switch?
Jeśli muszę to zrobić ręcznie to w jaki sposób?
W przykładach był poniższy kod ale nic się nie dzieje i mało tego wiem że ten sposób dodawania nie będzie działał po aktualizacji

binary_sensor:
  - platform: mqtt
    name: "okno"
    state_topic: "home/OpenMQTTGateway/433toMQTT"
    value_template: >-
      {% if value_json.value == '1595011' %}
        {{'ON'}}
      {% elif value_json.value == '1595017' %}
        {{'OFF'}}
      {% else %}
        {{states('binary_sensor.okno') | upper}}
      {% endif %}
    qos: 0
    device_class: opening

proszę o pomoc jak to ugryźć

Musisz dostosować kod do nowego formatu mqtt. Dla binary_sensor:

Dla sensor:

Dla switch:

Dla pozostałych:

Dziękuję za odpowiedź
Czy mogę prosić o jakiś przykład?

Jeśli zechcesz kliknąć w powyższe linki znajdziesz tam przykłady.

Nie potrafię sobie z tym poradzić (programowanie to dla mnie czarna magia)
robię tak:

mqtt:
  binary_sensor:
  name: "Window"
  state_topic: "home/OpenMQTTGateway/433toMQTT"
  value_template: >-
   {% if value_json.value == '1595011' %}
   {{'ON'}}
   {% elif value_json.value == '1595017' %}
   {{'OFF'}}
   {% else %}
   {{states('binary_sensor') | upper}}
   {% endif %}
  qos: 0
  device_class: opening

Przy sprawdzaniu konfiguracji otrzymuję:
Invalid config for [mqtt]: [name] is an invalid option for [mqtt]. Check: mqtt->mqtt->name. (See /config/configuration.yaml, line 21).

gdzie jest błąd?

Trudo Ci pomóc ponieważ wklejasz nie sformatowany tekst, wpis powinien zaczynać się:

mqtt:
  binary_sensor:
    - name: "Window"

Pamiętaj o odpowiednich wcięciach.

image

mqtt:
  binary_sensor:
    - name: "Drzwi wejściowe"
      state_topic: "dom_BEF65A/tele/RESULT"
      value_template: '{{value_json.RfReceived.Data}}'
      payload_on: "066483"
      payload_off: "066489"
      device_class: Door
      qos: 1

Ja mam tak porobione wszystkie czujniki i u mnie działa.

Masz powyżej przykład jak to zrobić a Ty dalej swoje.

mqtt:
  binary_sensor:
    - name: "Window"
      state_topic: "home/OpenMQTTGateway/433toMQTT"
      value_template: >-
      {% if value_json.value == '1595011' %}
          {{'ON'}}
      {% elif value_json.value == '1595017' %}
          {{'OFF'}}
      {% else %}
      {{states(‘binary_sensor’) | upper}}
      {% endif %}
      qos: 0
      device_class: opening

Dodatkowo masz jakiś dziwny format apostrof

“
‘

pewnie prze kopiowanie.
Oczywiście nie wchodziłem w poprawność powyższego kodu tylko jego poprawne formatowanie.

1 Like

Dzięki koledze MarcO encje wreszcie się pojawiły. Dziękuję
walczę teraz z połączeniem z OpenMqttGateway który wywaliłem z home assistanta i nie chce mi się ponownie dodać

Edit:

Udało się ale nie całkowicie.
Możecie mi wytłumaczyć dlaczego działa tylko czujnik który jest opisany niżej? (w typ przypadku Eliza).
Jeśli zamienię kody miejscami to działa Dawid.
Kody są prawidłowo odczytywane z obu czujników.
image

Definicję “mqtt:” używasz tylko raz na początku, tak samo jak “binary_sensor”

@Marcin.Szczepaniak
Kod (jakikolwiek, ale YAML w szczególności, bo w nim kluczowe jest formatowanie tekstu) wstawiasz na forum używając linijek zawierających po 3 odwrotne apostrofy (to ten spod klawisza tyldy, ale NIE ten spod klawisza cudzysłowu!).
Takie linijki przed i po wklejce - zobacz jak zedytowałem twoje posty.
Grafika/screenshoty może być uzupełnieniem tekstu, ale nie główną treścią - ułatw życie odpowiadającym!

PS to samo na githubie (choćby w issuees) czy dowolnym innym forum używającym formatowania MarkDown.