Problem z gniazdkiem elektrycznym

Witam wszystkich. Mam taki dziwny problem z gniazdkiem Smart . Mianowicie, wykorzystuje je do monitorowania zużytej energii z paneli fotowoltaicznych . Zintegrowane to mam wszystko w Home Asystencie z kartą energia. Jestem off-gridowcem i posiadam magazyn energii. Z uwagi na ograniczenia mojego magazynu, mam skonfigurowane na inwerterze wyłączanie przetwornicy w godzinach nocnych, aby na pusto nie pobierała mi energii i w tym czasie moje Smart gniazdko nie ma zasilania. Po powrocie zasilania gniazdko przekłamuje całkowite zużycie energii,


zmniejsza je do stanu z przed 14 godzin i co za tym idzie w zakładce energia mam ujemne przyrosty prądu. Gniazdko jest pod zigbee. I zastanawiam się czy można by to było jakoś obejść aby były poprawne wskazania w Home Asystencie.

Udało Ci się znaleźć rozwiązanie Twojego problemu?

Nikt chyba nie odgadł co autor miał na myśli mówiąc o poprawnych wskazaniach.

Odgadł :wink: - tylko ile można klepać o tym samym w koło?

Rozwiązanie jest już na tym forum - utworzyć własny licznik energii na podstawie mocy odczytywanej z gniazdka.

1 Like

Myślałem że te 14 godzin gdy Gniazdko jest wyłączone :stuck_out_tongue_winking_eye:

Problem jest w samym gniazdku, że się resetuje po zaniku zasilania i nie zapisuje (zapamiętuje) pomiarów cząstkowych.
To jest dobre bo w prostych rozwiązaniach zapisuje się to w pamięci flash, która ma ograniczoną ilość zapisów.
Widać to np. w Tasmocie w statystyka ilości “przeprogramowań” jeśli ustawisz save data, więc na własne życzenie zabijasz układ.

To jest niedobre bo się resetuje :stuck_out_tongue:

1 Like