Problem z instalacją HA RPi 3

Cześć!
Mam do Was prośbę o pomoc w instalacji HA na Raspberry Pi 3 B+. Kupilem uzywany zestaw Raspberry Joy-It do obslugi HA, niestety podążając za instrukcjami instalacji mam błąd.
Zmieniałem karty SD, pendrive, nie pomaga. Formatowalem go na Fat32.
Moze macie jakiś pomysł jak ten problem rozwiązać?
Z góry dziękuję!

Error mounting /dev/sda3 at /media/pi/disk: Command-line 'mount -t" squashfs" -o “uhelper=udisk2, nodev, nosuid " " /dev/ sda3 " " /media/pi/disk” exited with non-zero exit status 32:
Mount: wrong fs type, bad option, bad superblock on /dev/sda3, missing codepage or helper program, or other error

cześć. A to czytałeś? https://arturhome.pl/instalacja-homeassistant/
Instalacja na RPI3 jest identyczna tylko obraz inny

Cześć czytalem, obraz dalem na b3+

ciekawe. nie spotkałem się wcześniej z takim problemem. A możesz zobaczyć czy jakiś inny linux zainstaluje się bez problemu?

1 Like

Witaj @Matis1993r
Spróbuj podłączyć zewnętrzny dysk / pendrive z obrazem HA lub innym systemem Linux np.: Raspberry Pi OS (32-bit) with desktop
Jeżeli pójdzie z zewnętrznego dysku/pendriva to może oznaczać że albo masz uszkodzoną kartę SD, albo sam czytnik w RP - to ostatnie sprawdzisz, jeśli użyjesz innej karty SD.

1 Like

Ja co prawda mam Raspbery Pi 4 ale to kwestia obrazu. Postępowałem zgodnie procedurą ze strony https://www.home-assistant.io/getting-started/. W tym poradniku jest ustawienie stałego adresu. Ale to nie jest Twój przypadek. Rozumiem, że wgrałeś na kartę SD obraz programem “balenaEtcher”, podłączyłeś monitor i klawiature do mailiny i obserwujesz jak się bootuje. Rozumiem, że na tym etapie widzisz błędy.

wgrywałem HA na raspbery pi3 i nie miałem żadnych problemów z tym.