Problem z uruchomieniem HA

Potrzebuję pomocy. Wczoraj aktualizowałem repozytoria z HACS (atomic calendar i Xiaomi ble) i po ponownym uruchomieniu mam komunikat ze HA uruchamia się i nie wszystko będzie dostępne… problem w tym, ze nic więcej się nie dzieje. Nie mogę zlurichonic serwera ponownie, nie mogę przywrócić backupu… jest jakaś szansa na uratowanie go bez ponownej instalacji?

A dałes mu szansę się uruchomić. Czasami to może długo trwać. Masz jakieś logi?

1 Like

Ja mam takie komunikaty w trakcie uruchamiania. Po odświeżeniu widoku strony po uruchomieniu HA błędy znikają.

Dalem. Zostawiłem go na noc i niestety rano dalej to samo. Jestem już poza domem, chciałem sprawdzić logi ale z zewnątrz nie mogę się dostać :unamused:
Wrócę wieczorem to sprawdzę czy mogę zalogować się lokalnie i postaram się wrzucić jakieś logi

wczoraj niechcący kliknąłem update HA do wersji 115 i wysypały się wszystkie sonoffy (cała integracja), na szczęście przywróciłem HA ale z przed 1 dnia. Ja czekam jak będą jakieś poprawki, bo jeszcze tak źle nie miałem.
Zainstaluj HA od nowa i przywróć backup z google, nie zajmie ci do dużo czasu 1h-2h i system ożyje

Szczerze mówiąc wolałbym go jakoś uratować. Ale jak się nie uda to postawię od nowa.

Wczoraj też mi padł bez opcji połączenia się z nim właśnie po próbie upgrade`u Hassio
W proxmox na podglądzie stracił IP, i zawieszał się na dobre. Nie mogłem nawet zastopować maszyny.

zwróćcie uwage czy w proxmoxie nie ma wykrzyknika na maszynie, jak jest to może być problem z przepełnionym dyskiem local-lvm (pve), w tedy tzra cos usunąć i maszyny wrócą do życia, kiedyś miałem taki problem

Teraz dopiero mam dostęp do logow. Baza się wysypała?

może problem jest z dyskiem, może są jakieś uszkodzone sektory, moja baza jest standardowa z HA i jak coś jest nie tak do Delete, restart i HA zakłada sobie nową bez problemu. Pytanie na czym stoi HA, bo jak pracuje na microSD to może karta umiera

HA mam na RPi4 i karcie SD. HA padł po aktualizacji repo z HACS wiec może to nie jest wina karty.
@luki25 jak skasować bazę?

w katalogu config jest home-assistant_v2.db. ten plik usuń i restart. Ja obstawiam na karte SD, też mi sie cuda działy przy aktualizacji, pierwszy raz problem był z karta, drugim razem zapełnniony Ram, ale tym masz pewno 4GB, wiec powinno chodzić. Po za tym zwróć uwage na wielkość tego pliku. Jak miałem prawie 1GB to nie chciału iść aktualizacje, wiec warto usunąć do przed aktualizacja. A tak w ogóle to musisz ograniczyć rozrastanie tego pliku, oczywiście jak jest z nim problem. Mam obecnie nie wiekszy niż 80mb

Pamiętaj, że usuwając plik home-assistant_v2.db tracisz historię wszystkich czujników, automatyzacji itd.

1 Like

jeżeli używa tej historii, ja nie maiłem żadnych problemów, ale słuszna uwaga

Spróbowałem wyczyścić bazę ale po tym zabiegu HA wcale nie wstaje. Zostaje mi ponowna instalacja. Ale teraz przerzucę się na USB. Mam Dysk SSD 500GB ale nie mogę z niego bootować RPi.
Myślicie, że system na pendrive 3.0 to wystarczająca opcja? Jeszcze przez moment wolę zostać na RPi a myślę, że będzie trochę szybciej i stabilniej.

Mam też problem z uruchomieniem HA na Proxmox. Nagle nie mogę uruchomić HA, nic nie pomaga, na proxmoxie widzę żółty wykrzyknik ale nie mogę dostać się do plików z HA , co mogę zrobić czy tylko pozostaje nowa instalacja, dysk to 50 GB na T620

wydaję mi się, że jeżeli masz wykrzyknikiem, to masz przepełniony dysk local-lvm, tam nie może być zajętego miejsca ponad 80%, bo ci będą się dziać takie cyrki, szczególnie że masz dysk 50gb, kup większy dysk i postaw proxmoxa od nowa na nim i zrób migrację backupa czyli backup maszyny HA i rozpakuj go na nowym proxmoxie

2 Likes

Jak duży dysk musiałbym zaistalować na HP T620 żeby mieć spokój na dłuższy czas

Tu nie chodzi o wielkość dysku, tylko co na nim zapisujesz, że 50GB nie wystarcza?

1 Like

Robiłem kiedyś (raczej ponad rok temu) eksperymenty w rodzaju instalacji HA na karcie 4GB (jako natywna instalacja bodajże na Odroidzie MC1solo, (a chyba też na RPi3?), na tej podstawie twierdzę, że absolutne rozsądne minimum to 16GB by brak wolnego miejsca nie był głównym problemem dnia. Natomiast jako rozsądną wielkość ssd do pracy HA uważam koło 128GB (ze względu na ciągły przemiał bazy danych - sam używam 120GB w zdalnej istalacji i 250GB w lokalnej (na której pozwalam sobie na eksperymenty).

HassOS na platformie x64 (obecnie znanej jako NUC, bo od tego chyba autorzy zaczęli z racji fajnej standaryzacji tej linii komputerków) idzie powolutku w stronę gotowego obrazu będącego w stanie natywnie pracować na dość dowolnej platformie amd64 (bez dodatkowej wirtualizacji w innym systemie - to załatwia wiele problemów, choć może nie każdemu odpowiada takie rozwiązanie - w tej chwili na ThinClient’ach jeszcze to chyba nie działa, ale obrazy dla NUC już działają na niektórych póki co intelowskich laptopach).

W przypadku wirtualizacji pewnie wymagania będą nieco większe, bo trzeba też przewidzieć miejsce na system hosta (no i pamiętać, że każdy system wymaga wolnego miejsca do swojej poprawnej pracy).

Na obrazku dysk 240GB=224GiB w takiej średniej instalacji (czyli zajęte koło 25GB-30GB ale trochę sobie pozwoliłem na śmietnik)

1 Like