Problem z urządzeniami zigbee dla Home Assistant Core 2022.3.5

Cześć, dla urządzeń zigbee z kilkoma encjami takich jak włączniki podwójne czy potrójne ponadawałem nazwy i typ light bezpośrednio w pliku configuracyjnym zigbee2mqtt. Wygląda to tak:
image

Po aktualizacji Home Assistant Core do wersji 2022.3.5 tak przerobione encje znikają z HA. Obecnie mam wersję Core 2021.12.9 i wszystko działa.
Czy ktoś ma pomysł o co chodzi?

Jeśli dobrze pamiętam to od wersji 1.24.0-1 Z2M nie działa ręczna zmiana switch na light. Dla testu przywróć “oryginalny” typ tych urządzeń czyli switch.

Pokazały się jako switch, tylko to bez sensu. Będzie to poprawione, czy już nie ma szans i trzeba na light zmieniać już w HA?
image

To pytanie należy skierować do Twórców HA i Z2M.

Na chwilę obecną jest taka możliwość.

1 Like

no to zostaję przy Core 2021.12.9

ale działa ja mam 2022.3.5 i zmienione switch na light

light:
  - platform: switch
    name: Lampka u Oliwii
    entity_id: switch.gniazdko_sciana

i bez problemu widzi jako light

image

Przeczytaj dokładnie o czym pisze @cino111. Zmiana typu w HA działała i działa.

Nie chcę zmieniać w HA tylko w configuration.yaml na zigbee2mqtt
Zmienię instancję HA i wszystko od nowa trzeba konfigurować. Chcę tego uniknąć.
Niby to powinno działać

image

ale coś dla kilku przycisków mi nie działa. Sprawdzał ktoś tę nową konfigurację?

rzeczywiście przepraszam nie doczytałem że z2m … zasugerowałem się tytułem

Cześć,
w configu zigbee2mqtt mam na włącznikach 2 i 3 przyciskowych encje pozamieniane na light, czyli:

 '0x680ae2fffe096de2':
    friendly_name: salonn
    homeassistant:
      switch_l2:
        type: light
        object_id: light_l2
      light_l2:  
        name: za sofa
        value_template: null
        state_value_template: '{{ value_jonson.state_l2 }}'        
      switch_l1:
        type: light
        object_id: light_l1
      light_l1:      
        name: salon sufit
        value_template: null
        state_value_template: '{{ value_jonson.state_l1 }}'     

i te encje w HA po aktualizacji jakoś styczniowej czy nawet wcześniej wyświetlają się jako stan nieznany.
image

jak klikam na te “pioruny” to światło się zapala i gasi, tylko z pozycji HA nie wiem w jakim obecnie jest stanie
image

Ręce już mi opadają. Ma ktoś pomysł co ja mam nie tak?

Pytasz ponownie o to samo tworząc nowy temat. Nic się w tej kwestii nie zmieniło - w Z2M nie działa ręczna zmiana switch na light. Od tego masz opcje w HA.