Przełącznik ścienny TUYA brak potwierdzeń

Mam przełącznik ścienny ( 3 przyciski bez N) pod Tuya. Z aplikacji Tuya z telefonu działa dobrze, ale z HA nie mam potwierdzeń włączenia. Sterować można ale nie ma potwierdzeń zwrotnych. Czy można to ogarnąć w HA?
Widziałem w sieci info że Tuya tak właśnie ma. Jeżeli nie w HA to myślę o zmianie oprogramowania w przełączniku na Tasmote, pytanie tylko jak to zrobić?

To dlaczego już nie kupuje Tuya, opóźnienia przy przełączaniu, częste problemy z włączeniem przełącznika znikające stany przełącznika. Tuya jest dobra wewnątrz swojego systemu ale połączenie z HA już jest kiepsko. Są dwa sposoby “OTA” i “Lutowanie kabli” . OTA trzeba sobie postawić jakiegoś linuxa na PI Proxmox lub inny https://www.youtube.com/watch?v=dt5-iZc4_qU . Jeżeli chodzi o lutowanie to rożnie z tym jest. Powiem tak firmy które zajmują się profesjonalnie zmiana firmware nie chcą tego robić bo wiążę się to z lutowaniem, przerywaniem ścieżek do innego okładu lub czasem jest to niemożliwe ze względu na współistniejące układy które mają wewnętrzny firmware. Pozdrawiam.

Jezeli połączyłeś już włącznik z aplikacją Tuya to nie polecam flashowac go OTA. Ja tak uwaliłem swoją żarówkę… Po sparowaniu z aplikacją aktualizuje się oprogramowanie i OTA często później kończy się niepowodzeniem.

Nadal możesz flashowac ale najpierw musisz usunąć urządzenie z aplikacji Tuya, to jest warunek konieczny do rozpoczęcia flashowania. Ze strony projektu:
To ensure the best chance of success, do not connect your device with the official app as it may automatically update the device, preventing you from flashing with tuya-convert.

Na szczęście kupiłem tylko jeden przełącznik do testów, to teraz protestuję flashowanie.
Jeżeli, tak jak piszecie TUYA jest kiepska to co innego? Sonof? Shelly?
Na chwilę obecną szukam wyłączników światła (szklane) oraz wtyczek go gniazdka.

Czy wyłączniki TUYA w wersji ZigBee też stwarzają problemy?

Raczej nie chodzi tutaj, że “Tuya jest kiepska” tylko integracja HA z ekosystemem Tuya jest kiepska z uwagi na ograniczenia chmury Tuya (opóźnienia itp). Wystarczy do takiego urządzenia wgrać alternatywne oprogramowania np. Tasmota i wszystko lokalnie (bez chmury) działa poprawnie :slightly_smiling_face:.

Najwięcej recenzji przełaczników/gniazdek WiFi/Zigbee znalazłem na stronie https://hejdom.pl

Sonoff + tasmota firmware, lub sonoff w HA działa to bez chmury z tego co kojarzę. Shelly mam czujniki zalania (można wyłączyć chmurę) z ciekawych opcji Shelly flood jest to ze podczas czuwania działa tylko moduł wykrywania zalania a dopiero po wykryciu uruchamiany jest moduł wifi (oszczędność baterii )

Po długich bojach udalo mi się (jeszcze nie do końca) uruchomić przełącznik Tuya w tasmota.
Mam tak, przełącznik 3 przyciski Tuya po wifi bez N, wygrałem przy pomocy tuya-convert oprogramowanie tasmota. I to kilka tematów:

  1. W tasmota nie znalazlem tego czujnika, jesttylko tuya mcv (chyba) ale na tych ustawieniach nie dziala. Stad zostawilem ustawienia generic i pozmienialem Template , metodą porównań do znalezionych w sieci oraz prób i błędów, znalazlem konfigurację przy ktorej dziala. Pytanie czy jest jakieś inne rozwiazanie
  2. Po zmianie na Tasmota wylacznik dostal spore opóźnienie załączenia kanałów lokalnie, czy to narmalna praca?
  3. Skonfigurowalem Tasmote do mqtt ale HA go nie widzi

ad: 2 zwiększ częstotliwość raportowania czujników, wpisz w konsoli tasmoty:

Teleperiod czas w sekundach

ad. 3 włącz automatyczne wykrywanie - wpisz w konsoli tasmoty polecenie:

SetOption19 1

Częstotliwość można ustawić ponizej sekundy?

Poczytaj sobie ten temat, bardzo fajnie jest opisana tasmota w HA. Tasmota - HA
Dla Twojego przełącznika to będzie chyba najlepsze:

SetOption59 1 - enables sending of tele/%topic%/STATE on POWER and light related commands
switch:
  - platform: mqtt
    name: "Tasmota Switch 1"
    state_topic: "stat/tasmota/RESULT"  
    value_template: "{{ value_json.POWER1 }}"
    command_topic: "cmnd/tasmota/POWER1"
    payload_on: "ON"
    payload_off: "OFF"
    availability_topic: "tele/tasmota/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
    qos: 1
    retain: false
  - platform: mqtt
    name: "Tasmota Switch 2"
    state_topic: "stat/tasmota/RESULT"  
    value_template: "{{ value_json.POWER2 }}"
    command_topic: "cmnd/tasmota/POWER2"
    payload_on: "ON"
    payload_off: "OFF"
    availability_topic: "tele/tasmota/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
    qos: 1
    retain: false
  - platform: mqtt
    name: "Tasmota Switch 3"
    state_topic: "stat/tasmota/RESULT"  
    value_template: "{{ value_json.POWER3 }}"
    command_topic: "cmnd/tasmota/POWER3"
    payload_on: "ON"
    payload_off: "OFF"
    availability_topic: "tele/tasmota/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
    qos: 1
    retain: false

ja mam przełącznik. sonoff i działa bardzo dobrze z HA. Tak jak powiedział @artpc sonoff może działać bez chmury wystarczy że raz pobierze “ID” urządzenia.
Ostatni autor dodał nawet opcje pracy w combo, więcej tutaj

1 Like

@Mario ale kolega @jumpi555 ma przełącznik który pracuje w środowisku Tuya. Jeśli wgrał tasmotę na niego to również będzie mu elegancko działać, kwestia ustawień.

@rafkan ale kolega @jumpi555 pytał też o alternatywę więc jako posiadacz sonoffa mogę się wypowiedzieć że nie ma problemów z HA i potwierdzić to co mówił @artpc że działa również w LAN. Jeśli ktoś będzie to w przyszłości przeglądał może mu się to przydać, więc stwierdziłem że się wypowiem…

1 Like

ok jest tak

  1. po wykonaniu SetOption19 1 - MQTTwidzi już przełącznik

  2. Pojawiły się 4 encje, 3 z przełączników, niestety nie działają poprawnie, w sumie to działają jak chcą i to różnie. Zakładam że błąd jest w konfiguracji w Tasmocie.
    I tu pytanie, jakie dokładnie parametry wybrać w Tasmocie?

  3. ustawienia częstotliwości raportowania chyba dotyczy raportowani z Tasmoty do MQTT. Mi w tej chwili chodzi o czas pomiędzy naciśnięciem przycisku a zaświeceniem się światła. Bez udziału MQTT. Na oprogramowaniu TUYA nie było praktycznie żadnego opóźnienia , tu jest ok 1 sek ale jest to odczuwalne

@Mario nie odbieraj mojego wpisu jako wytyk do Twojej osoby, nia miałem tego na celu. Sam posiadam sonoffy zintegrowanerowane za pomocą “SonoffLAN”.

1 Like

znalazłem informację że parametr Teleperiod nie można ustawić mniej niż 10s. Jak dla mnie to trochę długo.

Tak zrobiłem + if SetOption26 is enabled - zgodnie z instrukcją. Niestety bez zmian.

W tej chili mam takie objawy:

  1. przyciski na przełączniku działają już szybciej, nie tak jak na TUYA ale ok,
  2. Tasmota z laptopa działa, jednak są duże opóźnienia od momentu wciśnięcia do zadziałania. Nie działa za każdym razem, trzeba odczekać chwilę.
  3. Z HA komunikacja jest, przełączanie nie działa. po próbie załączenia po kilku sekundach wraca do pozycji off. Często przy tym traci łączność na chwilę.
  4. zdarzało się że światło samo się zaświecało albo nie można było zgasić. Po rozłączeniu MQTT, sam włącznik działa.

Pewnie problem jest z doborem odpowiedniego “template” dla tego przełącznika.
Jeśli jeszcze tego nie robiłeś to stronie tasmoty są obsługiwane włączniki, potestuj te które najbardziej odpowiadają Twojemu. Tylko wcześniej zresetuj włącznik do defaultowych ustawień tasmoty.

Też się nad tym zastanawiałem, przetestowałem kilka ustawień, zostawiłem to które działa lokalnie. Jeżeli podpiął bym złe piny to włącznik nie działał by w ogóle. Ustawienie które zostawiłem działają na wyłączniku. Problemem są opóźnienia oraz interpretacja w MQTT. Tak mi się wydaje.