QNAP + HA + Conbee 2

Zainstalowałam na QNAP TS-253D (QTS 4.5.2) Home Assistant w VirtualizationStation 3. Do zestawu dołączyłam Conbee II (najnowszy firmware 0x26680700). Dołączyłam USB, jest widoczne w HA. Po zainstalowaniu Zigbee2mqtt nie jest w stanie dołączyć żadnego urządzenia Zigbee (nie wyszukuje ich). Nie jestem w stanie rozszyfrować logów, czy ktoś z was może mi pomóc z tym problemem? Poniżej kilka screenów z logami i info o urządzeniach.

Dodatkowo logi z zigbee2mqtt:

Oraz config zgbee2mqtt:

Po pierwsze proponuję zmienić wpis w konfiguracji Zigbee2mqtt dotyczący portu na adres conbee
Zaznaczyłem Ci na czerwono o który chodzi.


Po wklejeniu go do konfigu powinno to wyglądać tak:

W kwestii parowania, jakie urządzenia chcesz podłączyć, przed parowanie aktywujesz opcje “Permit join”?

1 Like

Dziękuję za propozycję rozwiązania problemu. Wpisałam adres portu zgodnie z sugestią i uruchomiłam ponownie serwer i dodatek zigbe2mqtt. Poniżej konfiguracja:

Oczywiście wcześniej już uruchamiałam zigbe2mqtt z włączeniem opcji wykrywania, ale poprzednie logi mogły być z któregoś uruchomienia. Poniżej logi z włączonym wykrywaniem:

Niestety nie zmieniło to sytuacji. Chciałabym zaznaczyć, że wcześniej miałam wpięty Conbee do RPi3 i parowało urządzenia bez większych problemów. Aktualnie próbuję dołączyć czujnik rucha Aqara i żarówki Ikea TRADFRI GU10 działające wcześniej w RPi3, ale w logach nie ma po nich śladu. Również uruchamiając ładowanie mapy (które trwa bardzo krótko w porównaniu z RPi3) nie pojawiają się żadne urządzenia poza koordynatorem. Brakuje mi już pomysłów co mogę sprawdzić. Chciałam jeszcze zaznaczyć, że są jakieś drobne problemy z podłączeniem w Virtualization Station USB, mianowicie zerwie połączenie na chwilę, trzeba ponownie podłączyć w oprogramowaniu i już trzyma połączenie. Czy macie jeszcze jakieś propozycje albo rozwiązaliście już taki problem u siebie?

Jeszcze kilka pytań, napisałaś, że wcześniej miałaś system na RPI - czy na qnapie stawiałaś HA od nowa czy przywracałaś ze snapshota?
Co prawda piszesz, że masz w zigbe2mqtt widocznego conbee ale sprawdź czy jest zamontowany w VM qnapa.
Czy masz poprawnie skonfigurowanego i działającego brokera?

Tak, HA zainstalowany na nowo, bez żadnych importów konfiguracji. Conbee jest zamontowany, screen poniżej. Urządzenie wpięte do portu USB 2.0

obraz

MQTT konfiguracja poniżej:

Dodatkowo sprawdziłam połączenie zgodnie z poradnikiem:

Broker MQTT działa poprawnie:

Wklej log ze startu addonu zigbe2mqtt (z tego miejsca)

Poniżej przedstawiam proces uruchomienia całego HA, znalazłam jeszcze coś niepokojącego w logach z systemu:

  1. Uruchomienie HA na Virtualization Station - niepokojący log z uruchomienia HA (zigbe2mqtt jeszcze nie uruchomione)

  1. Niepokojący wpis w konsoli:

  1. Log z uruchomienia zigbee2mqtt wraz ze zmianą na Permit join new devices i skanowaniem sieci. Po tym kilkukrotne uruchomienie czujnika ruchu Aqara do parowania. Nic nie wykrywał więc na chwilę przełożyłam Conbee do RPi3 ze starą konfiguracją sprawdzić, czy tam jest wszystko ok. Po usunięcia urządzenia (force remove) i ponownym uruchomieniu parowania wykryło bez problemów więc stick Conbee powinien być ok. Wrzucam w formacie json otwieralnym w Notatniku/Notepad++, jeżeli nie da się go otworzyć chętnie wrzucę w innym proponowanym formacie, ale ten wydawał się najbardziej czytelny.

log.json (29,9 KB)

Moje podejrzenia padają na jeszcze jedną rzecz, mianowicie problem na linii HA-QNAP-Conbee. Po włożeniu Conbee do QNAP kilkukrotnie pojawia się i znika ono w oknie poniżej, tak, ze ciężko jest je zamontować w Virtualization Station. Za każdym razem zmienia się nr magistrali. W końcu się udaje i zamontować i trzyma już połączenie. Po resecie VM sutuacja się powtarza. Czy to może mieć wpływ na mój problem?

obraz

Co pierwszej kwestii to ten warning pojawia się od momentu ostatniej aktualizacjii supervisiora która wprowadziła do dodatków informację o wykorzystaniu systemu.
W kwestii magistrali, jeśli do konfiguracji podałaś adres conbee (z logów wynika że tak) a nie numer portu to nie wpływa to na działanie HA.
W logach nie masz nic co by wskazywało na błędy ale mam jescze jedno pytanie - do qnapa podłączyłaś conbee na przedłużce czy bezpośrednio do gniazda usb?

Na chwilę obecną bezpośrednio do portu (przetestowany każdy, zarówno USB 2.0 jak i 3.0). Czekam na zamówioną przedłużkę.

Najprawdopodobniej tutaj może być problem i korzystaj z portu 2.0.

W sensie, że QNAP zakłóca odbiór sygnału dla częstotliwości Zigbee? Nie jest on wyposażony w moduł WiFi więc zakładałam, że nie będzie miał on wpływu na pracę urządzenia. Kupię dzisiaj przedłużkę i przetestuję. Z USB 3.0 skorzystałam tylko w celu przetestowania czy jest jakaś różnica, logi/testy wykonywane były z wpiętym stickiem do USB 2.0

Wczytaj się w dokumentację conbee gdzie producent wręcz zaleca montowanie sticka na co najmniej 30 cm przedłużce i w porcie 2.0. Przy jej zakupie nie oszczędzaj lepiej wydać kilka złotych więcej i mieć później spokój. Daj znać czy ruszy z przedłużką.

Hej!
Używam HA (co prawda to początki przygody) na Qnap’ie + VM (Debian + docker) razem z conbee II.
Generalnie wszystko działa, aczkolwiek wyszukiwanie urządzeń w zigbee2mqtt jest czasami problematyczne (może to kwestia moich błędów).
W ustawieniach zigbee2mqtt zostaw lepiej:
serial:
port: /dev/ttyACM0
adapter: deconz
u mnie działa w porcie usb 2.0 bez przedłużki.
Mam co prawda starszą wersję firmware do conbee II.
Miałem tak, że konkretne urządzenie znalazło mi dopiero po wypięciu z sieci na ok. 10 sekund, ponownym podłączeniu i resecie przyciskiem. Później problemów już nie było.

W VM rzeczywiście jest problem z montowaniem conbee; po restarcie zigbee2mqtt/deConz VM potrafi wywalić conbee; trzeba wejść do ustawień maszyny wirtualnej usunąć wszystkie widoczne usb (czasem potrafi być tak że masz np 4x zamontowane to samo conbee) i dopiero zamontować je jeszcze raz. Nie wiem jak ustawić, żeby conbee z automatu był przypisany do maszyny wirtualnej. Ale jak ktoś wie; to niech napisze;)

Wszystko wskazuje na to, że problem został zażegnany. Po podłączeniu Conbee przez przedłużkę USB zaczęło wyszukiwać urządzenia. Bez problemu dodałam 1x czujnik ruchu Aqara i 2x żarówka IKEA. Pozostawię to na kilka dni bez żadnych modyfikacji i będę obserwować logi. Martwi mnie dalej problem z zamonotowaniem Conbee w USB Virtualization Station (chwilowe znikanie i pojawianie się na różnym porcie). Widzę, że u kolegi Martinez wygląda to podobnie, ale dziwi mnie, że działa w takim razie z przedłużką.

Panie Rafale, bardzo dziękuję za pomoc w rozwiązaniu problemu. Zastanawiam się czy nie wymienić Conbee na CC2652P, może nie będzie problemu z tym zanikaniem w QNAP VM. Poczekam i poobserwuję zachowanie Conbee.

Po pierwsze jaki Panie, Rafał jestem i nie ma za co od tego jest to forum. Po drugie to “znikanie” (choć osobiście na swoim qnapie tego nie doświadczyłem a mam do niego podpięte 2 szt. conbee, CC2652P oraz dongla bluetooth) spowodowane jest sposobem “korzystania” z portów usb przez VM qnapa. Ja “odpinam” z VM podpięte w/w sticki tylko w przypadku robienia migawki HA oraz aktualizacji oprogramowania samego qnapa. Proszę pozostawić podpiętego conbee na przedłużce a co do portów tak jak Ci napisałem jeśli w konfiguracji masz podany adres sticka a nie port, HA sobie go “odnajdzie”.

Witam wszystkich serdecznie. Mam taki sam problem jak Sandra. HA postawiony na virtualnej maszynie z uprawnieniami supervisora na Qnapie 251+ , dongel Conbee II podpięty pod ta maszynę. Nie pomaga podpięcie go na przedłużce usb. Myślałem najpierw, że jest to wina niekompatybilnych urządzeń ale kupiłem SP111 i wymieniłem mu soft na Tasmod i pomimo ,że loguje się on jak i Zegbee2mqtt do Mosquitto brokera to nie widać ani koordynatora oraz innych urządzeń.
Poniżej logowania do mosquitto

[18:45:13] INFO: Setup mosquitto configuration
[18:45:13] WARNING: SSL not enabled - No valid certs found!
[18:45:13] INFO: Found local users inside config
[18:45:13] INFO: Initialize Hass.io Add-on services
[18:45:14] INFO: Initialize Home Assistant discovery
[18:45:14] INFO: Start Mosquitto daemon
1613411114: mosquitto version 1.6.3 starting
1613411114: Config loaded from /etc/mosquitto.conf.
1613411114: Loading plugin: /usr/share/mosquitto/auth-plug.so
1613411114: |-- *** auth-plug: startup
1613411114: ├── Username/password checking enabled.
1613411114: ├── TLS-PSK checking enabled.
1613411114: └── Extended authentication not enabled.
1613411114: Opening ipv4 listen socket on port 1883.
1613411114: Opening ipv6 listen socket on port 1883.
1613411114: Opening websockets listen socket on port 1884.
1613411114: Warning: Mosquitto should not be run as root/administrator.
1613411114: New connection from 172.30.33.1 on port 1883.
[INFO] found mqtt on local database
1613411115: New client connected from 172.30.33.1 as mqttjs_dabeb6ac (p2, c1, k60, u’mqtt’).
1613411118: New connection from 192.168.0.20 on port 1883.
1613411118: New client connected from 192.168.0.20 as Gniazdko Olaf (p2, c1, k30, u’mqtt’).
1613411123: New connection from 172.30.32.1 on port 1883.
1613411123: New client connected from 172.30.32.1 as 1e09bTGVkZan0TyPCTg1Ho (p2, c1, k60, u’mqtt’).
1613411134: Client mqttjs_dabeb6ac disconnected.
1613411153: New connection from 172.30.33.1 on port 1883.
1613411153: New client connected from 172.30.33.1 as mqttjs_a92935fa (p2, c1, k60, u’mqtt’).

a tu ze startu Zigbee2mqtt

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] socat.sh: executing…
[18:45:41] INFO: Socat not enabled, marking service as down
[cont-init.d] socat.sh: exited 0.
[cont-init.d] zigbee2mqtt.sh: executing…
[18:45:42] INFO: MQTT available, fetching server detail …
[18:45:43] INFO: Previous config file found, checking backup
[18:45:43] INFO: Creating backup config in ‘/share/zigbee2mqtt/.configuration.yaml.bk’
[18:45:43] INFO: Adjusting Zigbee2mqtt core yaml config with add-on quirks …
[cont-init.d] zigbee2mqtt.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[18:45:44] INFO: Handing over control to Zigbee2mqtt Core …

zigbee2mqtt@1.17.1 start /app
node index.js
CREATED DECONZ ADAPTER

Gniazdko SP111 jest urządzeniem WiFi nie podłączysz go do Zigbee. Z logów brokera wynika, że połączyło się do do niego (jeśli nazwałeś go “Gniazdko Olaf”)
Co do Zigbee2mqtt to wklej co wpisałeś w konfiguracji.

1 Like

Fakt dziękuję za uwagę. Gniazdko jak najbardziej jest widoczne w przełącznikach. Jednak nadal mam problem z samym koordynatorem i innymi sprzętami. Konfig Zigbee2mqtt

data_path: /share/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
mqtt:
base_topic: zigbee2mqtt
server: ‘mqtt://core-mosquitto’
user: mqtt
password: xxxxxxxxxxxxxxxx
serial:
port: /dev/ttyACM0
adapter: deconz
advanced:
log_level: warn
pan_id: 6754
channel: 11
network_key:
- 1
- 3
- 5
- 7
- 9
- 11
- 13
- 15
- 0
- 2
- 4
- 6
- 8
- 10
- 12
- 13
availability_blocklist: []
availability_passlist: []
device_options: {}
blocklist: []
passlist: []
queue: {}
frontend:
port: 8099
experimental: {}
socat:
enabled: false
master: ‘pty,raw,echo=0,link=/dev/ttyZ2M,mode=777’
slave: ‘tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5’
options: ‘-d -d’
log: false

Poprzednio miałem wpisane jak w poradniku na hejdom ale jak podpinałem gniazdko to zmieniłem na te co wkleiłem.