TUYA - gniazdka

Witam proszę o pomoc mam gniazdko wifi dodane już w HA , gniazdko zostało podłączone pod okap kuchenny i ma za zadanie że jak się włącze okap kuchenny a gniazdo wykryje zasilanie Wat powyżej 50 W to oczyszczacz powietrza startuje na ustalone obroty i wyłącza obecną automatyzację i to działa ale mam problem kiedy wyłączę okap wtedy mój oczyszczasz nie wraca do ustalonej automatyzacji muszę to zrobić ręcznie gdzie popełniłem błąd ??

''alias: okap
description: ""
trigger:
  - type: power
    platform: device
    device_id: 15100db68439495f918236447d0da0e4
    entity_id: 2c5ca616973a9802b75ff91a5cd16f21
    domain: sensor
    above: 50
    below: 200
condition: []
action:
  - device_id: 15eeacf59ad211629be75b9b8d536b70
    domain: number
    entity_id: 3cce81a4d791cea8fb76c23a713de6a2
    type: set_value
    value: 1300
  - service: automation.turn_off
    data:
      stop_actions: true
    target:
      entity_id:
        - automation.mi_air_purifier_3c_dynamiczne_sterowanie
        - automation.12_26_wylacz_led_i_przelacz_na_tryb_nocny
mode: single

udało mi się to rozwiązać ale dalej jest problem , utworzyłem 2 automatyzacje jedna że jak wartość powyżej 50 W to wyłącza obecne automatyzację i startuje oczyszczacz na obroty ustalone, druga automatyzacja to poniżej 50 W i wraca oczyszczacz do swojego pierwotnego stanu ALE jest taki problem ale to już chyba w samej automatyzacji że jak wartość PM na wyświetlaczu wynosi tylko 1 to żadna automatyzacja się nie uruchomi do tego momentu aż ta wartość się nie zmieni, jak to zmienić bo czasami powietrze mogę mieć na poziome PM 1 nawet pół dnia i żadna automatyzacja nie zadziała jak wartość się nie ruszy

alias: okap
description: ""
trigger:
  - type: power
    platform: device
    device_id: 15100db68439495f918236447d0da0e4
    entity_id: 2c5ca616973a9802b75ff91a5cd16f21
    domain: sensor
    above: 50
condition: []
action:
  - device_id: 15eeacf59ad211629be75b9b8d536b70
    domain: number
    entity_id: 3cce81a4d791cea8fb76c23a713de6a2
    type: set_value
    value: 1300
  - service: automation.turn_off
    data:
      stop_actions: true
    target:
      entity_id:
        - automation.mi_air_purifier_3c_dynamiczne_sterowanie
        - automation.12_26_wylacz_led_i_przelacz_na_tryb_nocny
mode: single

alias: okap off
description: ""
trigger:
  - type: power
    platform: device
    device_id: 15100db68439495f918236447d0da0e4
    entity_id: 2c5ca616973a9802b75ff91a5cd16f21
    domain: sensor
    below: 5
condition: []
action:
  - service: automation.turn_on
    data: {}
    target:
      entity_id:
        - automation.12_26_wylacz_led_i_przelacz_na_tryb_nocny
        - automation.mi_air_purifier_3c_dynamiczne_sterowanie
mode: single

moja główna automatyzacja

alias: "zhimi_airp_mb4a - dynamiczne sterowanie "
description: ""
trigger:
  - platform: state
    entity_id: sensor.zhimi_airp_mb4a_pm2_5
condition:
  - condition: time
    after: "8:30:00"
    before: "20:58:00"
action:
  - service: number.set_value
    data_template:
      entity_id: number.zhimi_airp_mb4a_favorite_motor_speed
      value: >
        {% set poziom_zanieczyszczen = states('sensor.zhimi_airp_mb4a_pm2_5')
        |float %}     {% if poziom_zanieczyszczen < 10 %}
          390
        {% elif poziom_zanieczyszczen < 16 %}
          760
        {% elif poziom_zanieczyszczen < 20 %}
          1280
        {% elif poziom_zanieczyszczen < 29 %}
          1430
        {% elif poziom_zanieczyszczen < 37 %}
          1490
        {% elif poziom_zanieczyszczen < 47 %}
          1560
        {% elif poziom_zanieczyszczen < 55 %}
          1740
        {% elif poziom_zanieczyszczen < 70 %}
          1820
        {% elif poziom_zanieczyszczen < 80 %}
          1900
        {% elif poziom_zanieczyszczen < 90 %}
          1999
        {% elif poziom_zanieczyszczen < 101 %}
          2000
        {% elif poziom_zanieczyszczen > 100 %}
          2100
        {% else %}
         2200
        {% endif %}
  - service: number.set_value
    data:
      value: "3"
    target:
      entity_id: number.zhimi_airp_mb4a_led_brightness

automatyzacja z trybem nocnym

alias: TRYB NOCNY
description: ""
trigger:
  - platform: time
    at: "20:59:00"
  - platform: state
    entity_id:
      - sensor.zhimi_airp_mb4a_pm2_5
condition:
  - condition: time
    after: "21:00:00"
    before: "8:29:00"
action:
  - service: number.set_value
    data:
      value: "1"
    target:
      entity_id: number.zhimi_airp_mb4a_led_brightness
  - service: fan.set_preset_mode
    data:
      preset_mode: Silent
    target:
      entity_id: fan.zhimi_airp_mb4a
mode: single

Zobacz co GPT odpowiedział :wink:

Wygląda na to, że twoja automatyzacja reaguje poprawnie na włączenie okapu, ale nie została poprawnie skonfigurowana, aby przywrócić poprzednią automatyzację po wyłączeniu okapu. Problemem jest brak odpowiedniego triggera do obsługi wyłączenia okapu.

Poniżej przedstawiam zmodyfikowaną wersję twojej automatyzacji, która powinna działać poprawnie:

alias: okap
description: ""
trigger:
  - platform: device
    type: power
    device_id: 15100db68439495f918236447d0da0e4
    entity_id: 2c5ca616973a9802b75ff91a5cd16f21
    domain: sensor
    above: 50
    below: 200
  - platform: device
    type: power
    device_id: 15100db68439495f918236447d0da0e4
    entity_id: 2c5ca616973a9802b75ff91a5cd16f21
    domain: sensor
    above: 0
condition: []
action:
  - service: number.set_value
    data:
      entity_id: number.3cce81a4d791cea8fb76c23a713de6a2
      value: 1300
  - service: automation.turn_off
    data:
      entity_id:
        - automation.mi_air_purifier_3c_dynamiczne_sterowanie
        - automation.12_26_wylacz_led_i_przelacz_na_tryb_nocny

W powyższym kodzie dodałem drugi trigger, który zostanie aktywowany, gdy moc okapu spadnie poniżej 50 W. Następnie w sekcji akcji przywrócono poprzednie ustawienia oczyszczacza powietrza.

Sprawdź tę zmianę i upewnij się, że działa zgodnie z oczekiwaniami. Jeśli nadal masz problemy, sprawdź również, czy entitety (np. number.3cce81a4d791cea8fb76c23a713de6a2, automation.mi_air_purifier_3c_dynamiczne_sterowanie, automation.12_26_wylacz_led_i_przelacz_na_tryb_nocny) są poprawnie zidentyfikowane i istnieją w twoim systemie Home Assistant.

dzieki za zainteresowanie, ogólnie to rozwiązałem swój problem stworzyłem automatyzację tak jak to wyżej wkleiłem i działa to poprawnie w 99 % problem jaki tu widzę to taki że jaka by nie była ustawiona automatyzacja to włącza się dopiero jak jednostka PM 2.5 zmieni swoją wartość, np. z 5 na 6 itd. wygląda na to że oczyszczacz wysyła dopiero wtedy sygnał do HA jak ta jednostka pm 2.5 się ruszy w górę albo w dół , i wtedy robi się problem jak na wyświetlaczu załóżmy mam uparcie tylko PM 1 powietrze jest czyste to nowa automatyzacja włączy się dopiero przy zmiennie PM czy idzię to jakoś zmienić żeby nie czekać na zmianę PM ??

dodam jeszcze że jak włączę okap to automatyzacja startuje od razu na ustalone obroty ale jak wyłączę okap i załóżmy mam PM 1 to dopiero wróci do swojej pierwotnej automatyzacji jak to PM się ruszy trochę namieszałem ale może mnie zrozumiałeś :slight_smile:

Twoja automatyzacją którą mi podałeś nie działa mi , działa tylko wyłączenie moich dziennych automatyzacji podczas włączenia okapu i nic się wiecej nie dzieje

1 Like

znasz może jakiś sposób aby automatyzacja od razu startowała ?? działa to poprawnie ale zawsze trzeba czekać na zmianę PM na wyświetlaczu

:thinking:A jakby dodać następny wyzwalacz np. szablon czasowy, co 5 minut będzie wyzwalał automatyzację

alias: "zhimi_airp_mb4a - dynamiczne sterowanie "
description: ""
trigger:
  - platform: state
    entity_id: sensor.zhimi_airp_mb4a_pm2_5
  - platform: time
    minutes: "/5"

W ten sposób wyzwalaczem będzie zmiana wartości senora lub/i okresowy wyzwalacz czasowy.

dzięki za zainteresowanie tematem, dodałem do kodu to co mi podałeś ale nie działa mi to wyskakiwał jakiś błąd:
[Message malformed: extra keys not allowed @ data[‘minutes’]

zrobiłem więc to w taki sposób i tez nie dział mi nie wiem w czym problem

Dla przykładu włączam tryb nocny czekam te ustawione 2 minuty i nie wskakuje automatyzacja ( dynamiczne sterowanie)

alias: "zhimi_airp_mb4a - dynamiczne sterowanie "
description: ""
trigger:
  - platform: state
    entity_id: sensor.zhimi_airp_mb4a_pm2_5
  - platform: time_pattern
    minutes: "2"
condition:
  - condition: time
    after: "8:30:00"
    before: "20:58:00"
action:
  - service: number.set_value
    data_template:
      entity_id: number.zhimi_airp_mb4a_favorite_motor_speed
      value: >
        {% set poziom_zanieczyszczen = states('sensor.zhimi_airp_mb4a_pm2_5')
        |float %}     {% if poziom_zanieczyszczen < 10 %}
          390
        {% elif poziom_zanieczyszczen < 16 %}
          760
        {% elif poziom_zanieczyszczen < 20 %}
          1280
        {% elif poziom_zanieczyszczen < 29 %}
          1430
        {% elif poziom_zanieczyszczen < 37 %}
          1490
        {% elif poziom_zanieczyszczen < 47 %}
          1560
        {% elif poziom_zanieczyszczen < 55 %}
          1740
        {% elif poziom_zanieczyszczen < 70 %}
          1820
        {% elif poziom_zanieczyszczen < 80 %}
          1900
        {% elif poziom_zanieczyszczen < 90 %}
          1999
        {% elif poziom_zanieczyszczen < 101 %}
          2000
        {% elif poziom_zanieczyszczen > 100 %}
          2100
        {% else %}
         2200
        {% endif %}
  - service: number.set_value
    data:
      value: "3"
    target:
      entity_id: number.zhimi_airp_mb4a_led_brightness

tryb nocny

alias: TRYB NOCNY
description: ""
trigger:
  - platform: time
    at: "20:59:00"
  - platform: state
    entity_id:
      - sensor.zhimi_airp_mb4a_pm2_5
condition:
  - condition: time
    after: "21:00:00"
    before: "8:29:00"
action:
  - service: number.set_value
    data:
      value: "1"
    target:
      entity_id: number.zhimi_airp_mb4a_led_brightness
  - service: fan.set_preset_mode
    data:
      preset_mode: Silent
    target:
      entity_id: fan.zhimi_airp_mb4a
mode: single

TRYB NOCNY

Wyzwalacz o 20:59:00 jest zbędny ponieważ warunek i tak go nie przepuści.

Akcjia:

preset_mode: Silent

Zmienia tryb na “Silent”, brakuje w innej automatyzacji by został zmieniony tryb na “Favorite” - tylko w tym trybie może działać “dynamiczne sterowanie”

:information_source:
Jeśli wyłączysz automatyzację przez automation.turn_off to ostatnia akcja przed zatrzymaniem będzie działała, czyli jeśli oczyszczać działa na poziomie np.

{% elif poziom_zanieczyszczen < 20 %}
          1280

Po wyłączeniu automatyzacji nadal będzie działał (urządzenie) lecz nie będzie zmiany prędkości
“dynamiczne sterowanie”

Mam inny model, więc mogą być inne tryby pracy.
Zamiast zmieniać na tryb Silent ustaw minimalną dla Favorite

Tylko że ja nie chcę aby moja automatyzacja “dynamiczne sterowanie” działała od 20:59 - 8:29 w tym czasie ma być tryb nocny jedynie co ma działać to automatyzacja “okap” po przekroczeniu 50W i gdy wyłączę okap to ma wskoczyć albo tryb nocny albo dynamiczne sterowanie zależy jaka jest godzina w danym momencie, wiem wiem trochę mieszam dlatego że brakuje mi wiedzy jak to wszystko teraz ułożyć czy możesz mi wkleić gotowy kod jak to ma wyglądać ostatecznie dla:
-dynamiczne sterowanie
-tryb nocny
-okap
-okap off (nie wiem czy to jest potrzebne ale inaczej nie umie tego zrobić )

z góry dzięki

Troszkę inne sposób:
Jedna automatyzacja
Wyzwalaczem jest przekroczenie 50 Watt na gniazdku

W tym kodzie, dzięki choose , mamy dwa różne zestawy działań w zależności od czasu. Jeśli jest między 8:30:00 a 20:59:59, to urządzenie działa w trybie “dynamicznego sterowania”. W przeciwnym razie, jeśli jest po 21:00:00 a przed 8:30:00 urządzenie zostanie przełączone w tryb cichy.

alias: Okap - Aktywuje . Dynamiczne / Ciche 
description: "Dynamiczne- 08:30:00-20:59:59 Cichy- 21:00:00-08:29:59"
trigger:
  - platform: numeric_state
    entity_id: sensor.moc_gniazdka  # Zastąp 'sensor.moc_gniazdka' rzeczywistym identyfikatorem encji dla gniazdka
    above: 50
condition: []
action:
  - choose:
      - conditions:
          - condition: time
            after: "08:30:00"
            before: "20:59:59"
        sequence:
          - service: fan.turn_on  # Włącza oczyszczacz powietrza 
            target:
              entity_id: fan.zhimi_airp_mb4a
            data: {}
          - service: number.set_value
            target:
              entity_id: number.zhimi_airp_mb4a_favorite_motor_speed
            data_template:
              value: >
                {% set poziom_zanieczyszczen = states('sensor.zhimi_airp_mb4a_pm2_5') | float %}
                {% if poziom_zanieczyszczen < 10 %}
                  390
                {% elif poziom_zanieczyszczen < 16 %}
                  760
                {% elif poziom_zanieczyszczen < 20 %}
                  1280
                {% elif poziom_zanieczyszczen < 29 %}
                  1430
                {% elif poziom_zanieczyszczen < 37 %}
                  1490
                {% elif poziom_zanieczyszczen < 47 %}
                  1560
                {% elif poziom_zanieczyszczen < 55 %}
                  1740
                {% elif poziom_zanieczyszczen < 70 %}
                  1820
                {% elif poziom_zanieczyszczen < 80 %}
                  1900
                {% elif poziom_zanieczyszczen < 90 %}
                  1999
                {% elif poziom_zanieczyszczen < 101 %}
                  2000
                {% elif poziom_zanieczyszczen > 100 %}
                  2100
                {% else %}
                  2200
                {% endif %}
          - service: number.set_value  # Zmień jasność oczyszczacza powietrza 
            target:
              entity_id: number.zhimi_airp_mb4a_led_brightness
            data_template:
              value: >
                {% if now().strftime('%H:%M:%S') >= '21:00:00' or now().strftime('%H:%M:%S') < '8:29:00' %}
                  1
                {% else %}
                  3
                {% endif %}
          - service: fan.set_preset_mode
            target:
              entity_id: fan.zhimi_airp_mb4a
            data_template:
              preset_mode: Favorite  # Tryb ulubiony, jeśli taki masz
      - conditions:
          - condition: time
            after: "21:00:00"
          - condition: time
            before: "08:29:59"
        sequence:
          - service: fan.turn_on  # Włącza oczyszczacz powietrza 
            target:
              entity_id: fan.zhimi_airp_mb4a
            data: {}
          - service: fan.set_preset_mode
            target:
              entity_id: fan.zhimi_airp_mb4a
            data:
              preset_mode: Silent  # Tryb cichy

Wyłącz swoje automatyzację związane z oczyszczaczem, wklej ten kod i przetestuj działanie.
Pisałem tą automatyzację na zasadzie kopiuj wklej z Twoich kodów i może gdzieś popełniłem błąd
/

Poprawiłem wcięcia przed linijką service: fan.turn_on w drugim bloku warunków.
:information_source:
W kodzie to co jest po “#:” (np. # Tryb cichy) jest komentarzem / opisem - jest zbędne a w szabloniedata_template nawet niedozwolone.

2 Likes

chyba dalej coś źle robię podmieniłem sensor ale dalej wyskakuje mi błąd

alias: Okap - Aktywuje . Dynamiczne / Ciche 
description: Dynamiczne- 08:30:00-20:59:59 Cichy- 21:00:00-08:29:59
trigger:
  - platform: numeric_state
    entity_id: sensor.okap_kuchenny_power
    above: 50
condition: []
action:
  - choose:
      - conditions:
          - condition: time
            after: "08:30:00"
            before: "20:59:59"
        sequence:
           - service: fan.turn_on
             target:
               entity_id: fan.zhimi_airp_mb4a
             data: {}
          - service: number.set_value
            target:
              entity_id: number.zhimi_airp_mb4a_favorite_motor_speed
            data_template:
              value: >
                {% set poziom_zanieczyszczen = states('sensor.zhimi_airp_mb4a_pm2_5') | float %}
                {% if poziom_zanieczyszczen < 10 %}
                  390
                {% elif poziom_zanieczyszczen < 16 %}
                  760
                {% elif poziom_zanieczyszczen < 20 %}
                  1280
                {% elif poziom_zanieczyszczen < 29 %}
                  1430
                {% elif poziom_zanieczyszczen < 37 %}
                  1490
                {% elif poziom_zanieczyszczen < 47 %}
                  1560
                {% elif poziom_zanieczyszczen < 55 %}
                  1740
                {% elif poziom_zanieczyszczen < 70 %}
                  1820
                {% elif poziom_zanieczyszczen < 80 %}
                  1900
                {% elif poziom_zanieczyszczen < 90 %}
                  1999
                {% elif poziom_zanieczyszczen < 101 %}
                  2000
                {% elif poziom_zanieczyszczen > 100 %}
                  2100
                {% else %}
                  2200
                {% endif %}
          - service: number.set_value
            target:
              entity_id: number.zhimi_airp_mb4a_led_brightness
            data_template:
              value: >
                {% if now().strftime('%H:%M:%S') >= '21:00:00' or now().strftime('%H:%M:%S') < '8:29:00' %}
                  1
                {% else %}
                  3
                {% endif %}
          - service: fan.set_preset_mode
            target:
              entity_id: fan.zhimi_airp_mb4a
            data_template:
              preset_mode: Favorite
      - conditions:
          - condition: time
            after: "21:00:00"
          - condition: time
            before: "08:29:59"
           - service: fan.turn_on 
             target:
               entity_id: fan.zhimi_airp_mb4a
             data: {}
        sequence:
          - service: fan.set_preset_mode
            target:
              entity_id: fan.zhimi_airp_mb4a
            data:
              preset_mode: Silent

Wczoraj poprawiłem kod (edytowałem)
Czy teraz działa?

podmieniłem co trzeba automatyzacją się zapisała i aktywuję się, wyłączyłem także wszystkie inne automatyzację ale po zmianie napięcia powyżej 50W nic się nie dzieje :frowning: chyba że ja coś źle robię

alias: Okap - Aktywuje . Dynamiczne / Ciche
description: Dynamiczne- 08:30:00-20:59:59 Cichy- 21:00:00-08:29:59
trigger:
  - platform: numeric_state
    entity_id: sensor.okap_kuchenny_power
    above: 50
condition: []
action:
  - choose:
      - conditions:
          - condition: time
            after: "08:30:00"
            before: "20:59:59"
        sequence:
          - service: fan.turn_on
            target:
              entity_id: fan.zhimi_airp_mb4a
            data: {}
          - service: number.set_value
            target:
              entity_id: number.zhimi_airp_mb4a_favorite_motor_speed
            data_template:
              value: >
                {% set poziom_zanieczyszczen =
                states('sensor.zhimi_airp_mb4a_pm2_5') | float %} {% if
                poziom_zanieczyszczen < 10 %}
                  390
                {% elif poziom_zanieczyszczen < 16 %}
                  760
                {% elif poziom_zanieczyszczen < 20 %}
                  1280
                {% elif poziom_zanieczyszczen < 29 %}
                  1430
                {% elif poziom_zanieczyszczen < 37 %}
                  1490
                {% elif poziom_zanieczyszczen < 47 %}
                  1560
                {% elif poziom_zanieczyszczen < 55 %}
                  1740
                {% elif poziom_zanieczyszczen < 70 %}
                  1820
                {% elif poziom_zanieczyszczen < 80 %}
                  1900
                {% elif poziom_zanieczyszczen < 90 %}
                  1999
                {% elif poziom_zanieczyszczen < 101 %}
                  2000
                {% elif poziom_zanieczyszczen > 100 %}
                  2100
                {% else %}
                  2200
                {% endif %}
          - service: number.set_value
            target:
              entity_id: number.zhimi_airp_mb4a_led_brightness
            data_template:
              value: >
                {% if now().strftime('%H:%M:%S') >= '21:00:00' or
                now().strftime('%H:%M:%S') < '8:29:00' %}
                  1
                {% else %}
                  3
                {% endif %}
          - service: fan.set_preset_mode
            target:
              entity_id: fan.zhimi_airp_mb4a
            data_template:
              preset_mode: Favorite
      - conditions:
          - condition: time
            after: "21:00:00"
          - condition: time
            before: "08:29:59"
        sequence:
          - service: fan.turn_on
            target:
              entity_id: fan.zhimi_airp_mb4a
            data: {}
          - service: fan.set_preset_mode
            target:
              entity_id: fan.zhimi_airp_mb4a
            data:
              preset_mode: Silent

Jakie masz tryby pracy ( ja mam inny model)


Tryb Auto - Automatyczna (ustawiona przez producenta)
Tryb Silent - Cichy
Tryb Favorite . Ten tryb pracy zostaje wykorzystany przez “dynamiczne sterowanie”.

Upewnij się, że wartość sensor.okap_kuchenny_power rzeczywiście przekracza 50 watt, gdy testujesz.

Sprawdź jeszcze raz poprawność nazw encji użytych w tej automatyce.

Sprawdź logi w Home Assistant, aby zobaczyć, czy są jakiekolwiek błędy lub ostrzeżenia związane z tą automatyzacją.

Kiedy masz otwartą automatyzację (kiedy edytujesz) i kiedy wyzwalacz spełni warunek above: 50 powinno być wizualne powiadomienie tego zdarzenia.
Kiedy jesteś w trybie edycji automatyki, kliknij w opcję ŚLADY (prawy górny róg)
Pojawi się coś takiego:


W tym oknie można zweryfikować działanie (wizualizacja działania)

Jeśl nadal nie będzie działać spróbuj do test użyć innego wyzwalacza np. włączenie światła to działanie wyeliminuje błąd wyzwalacza.

:information_source:
W HACS jest integracja Spook - przeszuka HA po względem błędów, porzuconych encji itp.

1 Like

zaraz to zacznę wszystko sprawdzać po kolei i szukać błędu ale powiedz mi czy tu nie brakuję jednej opcji bo w 1 poście napisałem że po przekroczeniu 50 W mój oczyszczacz ma wchodzić na 1300 obroty a poniżej 50 W wraca do automatyzacji ??

action:
  - device_id: 15eeacf59ad211629be75b9b8d536b70
    domain: number
    entity_id: 3cce81a4d791cea8fb76c23a713de6a2
    type: set_value
    value: 1300
  - service: automation.turn_off

pomijając już sam okap wywołałem także specjalnie żeby PM na oczyszczaczu wskoczył powyżej 50 i tez nic się nie dzieje


chyba rozwiązałem swój problem wracając do początku moich postów wróciłem do wcześniej utworzonych automatyzacji i do automatyzacji " okap off " dodałem tylko motor speed i ustawiłem swoją wartość np 390 , przy zmianie PM na oczyszczaczu i tak i tak wróci do swojej prawidłowej automatyzacji " dynamiczne sterowanie" ważne żeby po wyłączeniu okapu nie zostawał na obrotach jakie ustawiłem w automatyzacji “okap on”

Dziękuje oczywiście tobie za poświęcony mi tutaj czas, strasznie mam tu namieszane ale chyba to działa teraz

finalnie wygląda to tak :slight_smile:
“dynamiczne sterowanie” czyli dla mnie to tryb AUTO

alias: "zhimi_airp_mb4a - dynamiczne sterowanie "
description: ""
trigger:
  - platform: state
    entity_id: sensor.zhimi_airp_mb4a_pm2_5
condition:
  - condition: time
    after: "8:30:00"
    before: "20:58:00"
action:
  - service: number.set_value
    data_template:
      entity_id: number.zhimi_airp_mb4a_favorite_motor_speed
      value: >
        {% set poziom_zanieczyszczen = states('sensor.zhimi_airp_mb4a_pm2_5')
        |float %}     {% if poziom_zanieczyszczen < 10 %}
          390
        {% elif poziom_zanieczyszczen < 16 %}
          760
        {% elif poziom_zanieczyszczen < 20 %}
          1280
        {% elif poziom_zanieczyszczen < 29 %}
          1430
        {% elif poziom_zanieczyszczen < 37 %}
          1490
        {% elif poziom_zanieczyszczen < 47 %}
          1560
        {% elif poziom_zanieczyszczen < 55 %}
          1740
        {% elif poziom_zanieczyszczen < 70 %}
          1820
        {% elif poziom_zanieczyszczen < 80 %}
          1900
        {% elif poziom_zanieczyszczen < 90 %}
          1999
        {% elif poziom_zanieczyszczen < 101 %}
          2000
        {% elif poziom_zanieczyszczen > 100 %}
          2100
        {% else %}
         2200
        {% endif %}
  - service: number.set_value
    data:
      value: "3"
    target:
      entity_id: number.zhimi_airp_mb4a_led_brightness

“okap” gdy pracuje to :slight_smile:

alias: okap
description: ""
trigger:
  - type: power
    platform: device
    device_id: 15100db68439495f918236447d0da0e4
    entity_id: 2c5ca616973a9802b75ff91a5cd16f21
    domain: sensor
    above: 50
    for:
      hours: 0
      minutes: 0
      seconds: 0
condition: []
action:
  - device_id: 15eeacf59ad211629be75b9b8d536b70
    domain: number
    entity_id: 3cce81a4d791cea8fb76c23a713de6a2
    type: set_value
    value: 1500
  - service: automation.turn_off
    data:
      stop_actions: true
    target:
      entity_id:
        - automation.mi_air_purifier_3c_dynamiczne_sterowanie
        - automation.12_26_wylacz_led_i_przelacz_na_tryb_nocny
mode: single

“okap off” gdy okap nie pracuje

alias: okap off
description: ""
trigger:
  - type: power
    platform: device
    device_id: 15100db68439495f918236447d0da0e4
    entity_id: 2c5ca616973a9802b75ff91a5cd16f21
    domain: sensor
    below: 5
condition: []
action:
  - device_id: 15eeacf59ad211629be75b9b8d536b70
    domain: number
    entity_id: 3cce81a4d791cea8fb76c23a713de6a2
    type: set_value
    value: 400
  - service: automation.turn_on
    data: {}
    target:
      entity_id:
        - automation.12_26_wylacz_led_i_przelacz_na_tryb_nocny
        - automation.mi_air_purifier_3c_dynamiczne_sterowanie
    enabled: true
mode: single

na razie testuje i wszystko działa prosił bym jednak jeszcze o zostawieni wątku jako otwartego przez pewien czas ,

gdyby ktoś pytał dlaczego mam tak dziwnie poustawiane obroty a to dla tego że mój xiaomi czasami na nie których obrotach wydobywa wyjący dźwięk dlatego doprecyzowałem obroty do perfekcji żeby nie występowało to wycie :slight_smile:

1 Like

Ja bym raczej spytał dlaczego tak zatytułowałeś posta, swoją nazwą wprowadza w błąd, nie dotyczy ani nie rozwiązuje problemu z “gniazdkami” Tuya.

1 Like

post opiera się na wykorzystaniu gniazdka TUYA z HA + automatyzacja Xiaomi chętnie zmienię tytuł powiedz tylko na jaki żeby nie wprowadzał w błąd

Pomyśl sam jeśli tytuł brzmiałby “DŁUGOPIS” (bo go wykorzystuję) a dotyczył opisu “Bitwy pod Grunwaldem” to ktoś kto szuka opisu bitwy zwróciłby na to uwagę ? Post dotyczy automatyzacji / dynamicznego sterowania urządzeniem Xiaomi Air Purifier 3C a trigger czyli zmiana stanu jednego z parametrów eksponowanych przez Twoje gniazdko, którego użyłeś nie ma tu najmniejszego znaczenia, bo równie dobrze zamiast gniazdka mógłbyś użyć, czujnika temperatury, zmiany stanu media_playera czy przybycia kogoś do “strefy”, jest jednym z elementów automatyzacji. Ktoś kto zawita na forum, szukając rozwiązania dla siebie np. oczyszczaczem, czy nawilżaczem nie zajrzy do posta dotyczącego “problemu” z gniazdkiem Tuya.

1 Like