TuYa RH3040 czujnik ruchu, zrywa połączenie

Cześć, zakupiłem czujnik ruchu TuYa RH3040 po podłączeniu do Home Asistanta po Zigbee przez około 5s działa on poprawnie (w logach zigbee2mqtt widzę że wysyła wiadomości), ale potem jakby się zacina i więcej nie wysyła żadnych wiadomości. Po naciśnięciu przycisku na obudowie wysyła wiadomość, ale nigdy wtedy nie wykrywa ruchu. Czy ktoś miał podobny problem? Czy da się go jakoś cyklicznie “wybudzać” żeby cały czas trzymał połączenie :thinking:

Nie napisałeś z jakiej wersji zigbee2mqtt korzystasz z jakiego koordynatora.

Czy to ten sam problem?

koordynator: SONOFF ZigBee 3.0
wersja zigbee2mqtt: 1.27.0-1

Edit:
@ajakubek tak podobne, tylko u mnie zawsze nie wykrywa ruchu

A chociaż podejmowałeś jakieś standardowe próby naprawy sytuacji?
Mam na myśli:

  • usunięcie z z2m, przez standardowe “Usuń urządzenie” w GUI z2m, następnie zrestartowanie dodatku z2m oraz ponowną próbę dodania natychmiast po włączeniu trybu parowania w z2m, ponadto przy tym ponownym parowaniu sugeruję pobudzanie urządzenia w trakcie parowania choćby przez krótkie kliki bądź powodowanie wykrycia ruchu
  • wymianę baterii na w 100% nową

PS jaka wersja firmware koordynatora?

https://github.com/Koenkk/Z-Stack-firmware/blob/master/coordinator/Z-Stack_3.x.0/bin/CC1352P2_CC2652P_launchpad_coordinator_20220219.zip to dokładnie wrzucałem
Próbowałem usuwać i łączyć jeszcze raz, jeszcze spróbuje wymienic baterie bo to jest chyba ostatnie czego nie zrobiłem

To napewno nie jest wersja firmware do starego poczciwego CC2531 i zdecydowanie odradzam jakąkolwiek wersję Zigbee 3.x do tego sticka bo to nie może działać dobrze, za słaby sprzęt.

1 Like

faktycznie pomyliłem nazwy, dokładnie kupiłem SONOFF ZigBee 3.0 stick i zrobił flash firmwaru

Hehe dość odważne ruchy, jeśli nie wiesz jaki masz sprzęt :stuck_out_tongue:
Wersję softu koordynatora widać w
z2m → Ustawienia → O programie → Wersja oprogramowania koordynatora

Wersja Zigbee2MQTT: 1.27.2 commit: unknown
Typ koordynatora: zStack3x0
Wersja oprogramowania koordynatora: 20220219

to coś takiego jest dokładnie wpisane

Istnieje nowsza beta wersja firmware jest to 20220726, więc potencjalnie możliwy jest ruch “ostatniej deski ratunku”

(to powyżej jeśli nic innego nie pomoże, jakkolwiek czujnik PIR może być po prostu wadliwy lub nieobsługiwany, jeśli klikniesz model w z2m, to powinien się pokazać jakiś wpis w bazie kompatybilnego sprzętu Blakkadera - szukałem tam RH3040, ale najwyraźniej jest rozpoznawany inaczej - zapodaj też ten link, edit: dobra znalazłem
Samotech PIR Motion Sensor (SM301Z) Zigbee compatibility wydaje się być obsługiwany, w oficjalnej bazie też jest
TuYa RH3040 control via MQTT | Zigbee2MQTT)
Z opisu widzę, że ma czujnik antysabotażowy, czytałeś instrukcję?
Być może wymaga użycia fabrycznej stopki mocowania (tak tylko zgaduję).

ale wróćmy do standardowych ruchów - bateria i ponowne parowanie w sposób, który wyklucza timeout, dodatkowo można wykorzystać możliwość przełączenia koordynatora w stały tryb parowania, czyli zamiast klikać w obszar oznaczony na rysunku 1 można ustawić tryb na stałe czekboksem 2 i zmianę konfiguracji zatwierdzając przyciskiem 3


Po udanym sparowaniu należy tą funkcję wyłączyć (dlatego standardowo przycisk 1 wyłącza tryb parowania samodzielnie).

pobawiłem sie tym i chyba trafiła mi sie wadliwa sztuka :frowning: po wyciagnieci bateri i włozeniu jej jeszcze raz znowu, działa przez pare sekund i sie zacina. Leci wtedy duzo wiadomosci w logach i nagle przestają. Po tym czujnik juz nie działa

A próbowałeś wymienić baterię (bądź baterie, bo jak widać na linkach powyżej taki model mają całkiem różne produkty)?
Oczywiście na nowe, nie wiem wprawdzie jakie to ogniwa, ale bez względu na technologię każde podlegają samorozładowaniu, więc nawet nie używane po terminie ważności mogą się nie nadawać do użytku.

I dopiero potem sparować?

Jeszcze nie wymieniałem bo nie mam zapasowej w domu, ale znalazłem coś innego ciekawego


on po resecie sie nie łączy z koordynatorem :thinking: tak chyba nie powinno byc

To jest sieć mesh, nie ma obowiązku bezpośredniego połączenia z koordynatorem, ale tylko Ty wiesz czy jest powód do niepokoju, bo znasz rzeczywiste położenie urządzeń w przestrzeni.

PS oczywiście wszystkie żarówki stanowiące routery masz na stałe podpięte do zasilania?

tak, sa podpięte, ale w domu ta zarówka jest daleko i czujnik od zarówki dzieli gruba sciana

Dla testu może spróbuj sparować z nową baterią i przy koordynatorze. Może zatrybi. A jak nie to raczej padnięty.

pobawiłem sie tym na różnych bateriach i w różnych miejscach w domu i nic nie pomogło. Kupiłem na promocji na ali 2 czujniki z aqaury z 15 dniową dostawa i lecą do mnie a ten leci do zwrotu :frowning: