Wyświetlanie encji jako własnego obrazu

Witam . Mam problem z wyświetlaniem własnego obrazu w encji . Obraz chcę aby wyświetlał się z lokalnego pliku . Gdy wstawię adres tego pliku z zdalnego serwera to wszystko wyświetla się dobrze, natomiast gdy chcę aby obraz był wyświetlany z lokalnego katalogu, to się nie wyświetla . Obraz umieszczałem w HA w folderze “media”, a także w “www/local” Nie daje rady tego wyświetlić z pliku lokalnego . Mój kod wygląda tak:

type: custom:button-card
entity: switch.dach_l3
name: Gniazdko dach
icon: mdi:power-socket-eu
show_entity_picture: true
entity_picture: /local/oklesnaprawa1.jpeg/
theme: ios-dark-mode-blue-red
styles:
  card:
    - width: 120px
    - height: 110px
    - background-color: '#000000'
  name:
    - font-weight: bold
    - font-size: 11px
    - color: white
    - align-self: middle
    - padding-bottom: 4px
color_type_label-card: rgb(28, 128, 199)
state:
  - value: 'off'
    color: rgb(0, 255, 0)
  - value: 'on'
    color: rgb(255, 0, 0)
    blink: true
    styles:
      icon:
        - animation: blink 1.5s ease infinite

katalogu www

entity_picture: /local/oklesnaprawa1.jpeg

:information_source:Usuń ukośnik na końcu ścieżki

Niestety ale nie działa

A po wstawieniu adresu działa

czy local to katalog w folderze www? Twój plik z obrazem jest w folderze www czy jest w katalogu local, który mieści się w www ?

Obrazek ten umieściłem zarówno w

jak i

to w końcu masz .jpg czy jpeg ?

1 Like

Ma być jpeg . Już to pozmieniałem że w każdym jest jpeg, lecz obrazek nadal się nie wyświetla .

/local to jest www, a ty masz www/local
W przeglądarce http://192.168.1.220:8123/local/podworko.png
obraz w katalogu www

Chciałbym aby obrazek ładował się z folderu lokalnego . Powiedzmy że umieszczam obrazek w HA w folderze “media” . Jaką scieżkę powinienem wpisać w konfiguracji karty - entity_picture: /local/oklesnaprawa1.jpeg

homeassistant:
  media_dirs:
    media: /config/media

http://192.168.1.220:8123/local/media/997.mp3

/media/local/oklesnaprawa1.jpeg

Nic nie pomogło, lecz może ktoś podpowie dlaczego przy takim adresie obrazek się pokazał - entity_picture: /local/local/oklesnaprawa1.jpeg

bo umieściłeś obrazek w folderze o nazwie local w katalogu www

Tak ale dlaczego podwójne “local” . W poprzednich odpowiedziach napisałem -"Powiedzmy że umieszczam obrazek w HA w folderze “media” " , czyli- lokalny adres ip/media . Wy pisaliście że ma być ścieżka “/media/local/oklesnaprawa1.jpeg”

Gdzie jest Twój obrazek ? Media–> my media → …

  1. twój obraz jest w katalogu o nazwie “local” u mnie brama
 /media/local/brama/obrazek.jpg
  1. twój obraz nie jest w żadnym katalogu tylko widać go tam gdzie u mnie jest pustka
 /media/local/obrazek.jpg

Mojego obrazka nie ma tam gdzie to zaznaczyłeś


A pisząc w poprzednich postach że "powiedzmy że umieszczam obrazek w “media” "
kierowałem się widokiem w Sambie .

I to właśnie w tym widocznym tu folderze “media” jest mój plik .


kliknij i zobacz … wyraźnie to napisałem wyżej … czytaj uważniej.