Aplikacja na Androida. Jak dostać się z poza lokalnej sieci

Proszę o pomoc. Zarejestrowałem się na duckdns, pobrałem token itd ale plikacja nie może się połączyć z zewnątrz. Przekierowałem porty na ruterze i dalej nic.

A masz zewnętrzny adres IP?

Ten który nadał mi duckdns?

Nie, ten który masz od swojego dostawcy internetu.

Przepraszam za te pytania ale gdzie to mogę sprawdzić?
W ustawieniach rutera?

Ok. Wszystko działa. musiałem doinstalować NGINX Home Assistant SSL proxy

@Pokost ważne, że zadziałało

Dobrze, że działa ale to jest trochę dla mnie dziwny sposób :slight_smile: wiem, że się taki często zaleca ale to jest postawienie jednego serwera WWW aby kierował na drugi serwer WWW :slight_smile: Myślę, że można to ogarnąć odpowiednią konfiguracją sieciową. Jednak jak działa to działa :slight_smile:

Długo się nie nacieszyłem, po restarcie nie mogę się dostać ani z lokalnej ani z zewnętrznej. Otworzyłem porty 80, 8123, 443. Ale wczesniej działało. Dostałem sie z aplikacji na przesyle danych i zwariowałem ze szcześcia, zresetowałwm Maline i martwość… nic

Do puki nie zrestartuję wszystko jest ok, mam dostęp przez aplikację i przez sieć lokalną, po restarcie Maliny nie mogę się dostać z każdej strony. Ludzie pomóżcie bo od rana siedzę a za oknem piękna pogoda.

@Pokost podaj jaką masz konfigurację w pliku configuration.yaml dotyczącą “http:”
Oraz co masz wpisane w Konfiguracji HA w zakładce “Ogólne”

Configure a default setup of Home Assistant (frontend, api, etc)

default_config:
http:
base_url: mojadres.duckdns.org
ssl_certifcate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

Text to speech

tts:

  • platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

Usuń ten wpis:
http:
base_url: mojadres.duckdns.org
ssl_certifcate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem
I jeszcze jedno co masz wpisane tutaj:

Teraz nie mogę się dostać i sprawdzić co mam wpisane w Publiczny adres. Muszę postawić wszystko od nowa i zobaczę co tam jest. Usunę również wpis w configuration.yaml. Będę miał czas na to dopiero po południu. Dzięki za pomoc.

Co do configuration.yaml to powinieneś mieć sekcję http: ale bez base_url (parametr ten nie ma sensu od wersji 0.110). Zostaw odwołania do certyfikatów.
W sekcji tts: dodaj base_url: adres_zewnętrzny bo inaczej możesz mieć problem z działaniem ttsa (polecam też dopisanie language: pl)
I koniecznie musisz mieć poprawną konfigurację w ustawieniach ogólnych tak jak pokazuje to @rafkan

@artur, @Pokost napisał, że zainstalował sobie dodatek “NGINX Home Assistant SSL proxy”.
W konfiguracji w/w dodatku mamy napiane:
"In the configuration.yaml file, some options in the http: section are no longer necessary for this scenario, and should be commented out or removed:

  • ssl_certificate
  • ssl_key
  • server_port"
    Stąd moja podpowiedź aby te dane usunął ponieważ są one w tym dodatku.
    Następnie przy tym dodatku w ustawieniach publiczny adres wpisujemy bez portu 8123, tylko sam adres: https://mojanazwa.duckdns.org.
    I dopiero przy tych ustawieniach będzie działać.

@rafkan Masz racje. Zapomniałem o tym dodatku :slight_smile: dla mnie to trochę chińszczyzna :slight_smile: To w takim wypadku faktycznie te ssle do wywalenia

Przed przejściem na nabucasa walczyłem z tym dodatkiem, dlatego mój wpis.

Jeśli ktoś ma domowy internet LTE (zamknięte porty) a chciałby dostać się do HA jak i do całej sieci z zewnątrz jest darmowy sposób. Postawienie VPN gateway na ruterze, u mnie się sprawdza. Wszystko stoi na darmowym Google cloud “always free” a w domu mały router obsługujący openvpn.
Szczegóły tu : https://youtu.be/b7qr0laM8kA
Nie trzeba mieć urządzenia z tego filmu wystarczy dowolny router z openwrt

Przy takich kombinacjach zawsze też można skorzystać z nabucasa o której pisał @rafkan niby 20 PLN miesięcznie ale problemy z dostępem znikną, a kasa na dalszy rozwój ha jest dla twórców :smiley:

1 Like