HA + MEW + automatyczna aktualizacja Mosquitto = AWARIA

Uwaga na aktualizacje Mosquitto 6.2.0 - 4 h temu sama się zaaktualizowała i wysypała mi mqtt i aktumatyzacje. Przywrócenie wersji uratowało dane !!!

P.S. Chyba że jak coś źle robię, ale nie ruszam podstawowego HA od kilku miesięcy poza wymaganymi aktualizacjami.

U mnie podobnie, aktualizacja do 6.2 wysypała mqtt i automatyzacje. Przywracam dane.
EDIT: Przywracanie uratowało wszystko :smiley:

Jestem dość świeżym użytkownikiem HA, ale niczego takiego nie doświadczylem w wersji jak na foto


Ta aktualizacja nie wnosi radykalnych zmian, może mieliście dużo starsze wersję 6.1.0 lub niższe.

Miałem wersje 6.1.3 i do niej przywróciłem i wszystko wróciło do normy.

Gdyby ktos tak jak ja nie mial akurat backupu :wink: to rozwiazanie ktore zawsze pomoze jest tutaj How to downgrade any supervisor addon - Installation / Home Assistant OS - Home Assistant Community (home-assistant.io)

Wersja 6.1.3 będzie i tak wymagała aktualizacji (być może do wersji wyższej niż 6.2.0), bo nie działa w HAOS 10.0.

@arkop
W przypadku kluczowych w danej konfiguracji Dodatków warto mieć wyłączoną autoaktualizację, to nie jest pierwszy ani zapewne ostatni przypadek gdy aktualizacja rozwala działający konfig (u mnie na 3 instalacjach jest akurat wszystko OK, ale nie używam Supli), w przypadku miażdżącej większości Dodatków nie ma nawet funkcjonującego programu beta-testów (jaki jest dla samego HA i HAOS, właściwie jedyny Dodatek jaki znam mający oddzielny kanał beta to ESPHome, a mimo to jest on nieskuteczny, bo developerzy nie biorą pod uwagę możliwości normalnych użytkowników - jeśli cały program beta testów wersji marcowej trwał 2 dni, to kto z garstki betatesterów zajętych normalnym życiem miał czas na przetestowanie kilku kolejnych bet, które pojawiały się w odstępach czasowych mniejszych niż czas potrezbny na jakiekolwiek sensowne testy…).
Więc konieczne jest wykonywanie backupów cząstkowych (GUI je proponuje).

Zasadniczo nie da rady nie aktualizować na bieżąco (jako minimum uważam aktualizację wszystkiego na koniec każdego miesiąca, gdy “duże” wydania są już w dojrzałych wersjach z bieżącymi poprawkami), bo przeskok z zamierzchłej wersji do współczesnej może być bardzo trudny.
Niestety trzeba czytać notatki do wydań (release notes), bo HA jest projektem w ciągłej budowie i się po prostu zmienia.

Na moich trzech instalacjach aktualizacja do wersji 6.2 przeszła bez problemów, na dwóch z nich mam MEW 01 i wszystko działa.

U mnie aktualizacja automatyczna i w tym samym momencie przestały działać powiadomienia + dane z Supli. Była zrobona automatyczna kopia zapasowa i przywróciłem i jest ok. Tylko teraz pytanie co poszło nie tak bo to że będę to musił zrobić to rozumiem :slight_smile:

Zgłoś problem gdzie trzeba, widzę, że ktoś się za to już wziął, więc się tylko dopisz w issue

niestety podlinkowanie polskiej instrukcji nie jest żadnym sensownym posunięciem, (nikt tego nie wykorzysta, chyba że akurat jakiś Polak rozwiąże problem…)

Problem MUSI być w zrozumiały sposób opisany po angielsku, podejrzewam, że może dotyczyć konfiguracji wykorzystującej mqtt-bridge (no właściwie nabieram 100% przekonania, że właśnie o to chodzi).

Brak problemów po aktualizacji.

Używasz mostu Supli ?

Ja używam mqtt-bridge, ale akurat nie z Supla i u mnie problem z działaniem mostka MQTT nie występuje.
Za to zwróciliście mi uwagę na inny problem - mam niestandardową integrację z TV Hisense i WoL w nim przestał działać, choć mostek działa OK, więc potencjalnie przyczyna może być inna (była cała masa aktualizacji w ostatnich dniach, więc u mnie na liście podejrzanych jest teraz HA i Supervisor).

bridge with Supla

Temporary solution is to set debug: true in mosquito broker configuration - after this it work correctly
Tymczasowym rozwiązaniem jest ustawienie debug: true w konfiguracji MQTT

2 Likes

image
to jest to??

Nie wiem co pokazujesz (chyba ostro przegiąłeś z zamalowywaniem, tak naprawdę szokująco mało tzw. danych “wrażliwych” można znaleźć w GUI), ale nie wygląda to na konfigurację Mosquitto…

PS Szukałbym w konfiguracji Dodatków (a raczej konkretnego Dodatku) a nie w Integracjach.

Stawiam że to tutaj:

Logi błędów MQTT w HA
configuration.yaml


logger:
  default: warning
  logs:
    homeassistant.components.mqtt: debug

I chyba znowu się cieszę z tego, że postawiłem sobie to na osobnym dockerze, a nie jako dodatki do HA. Bo sam Mosquitto nie zmienił się od dawna:


Ciekawe, że sam dodatek dopiero teraz zmienia wersję, która już jest od sierpnia.

1 Like

Podobno wystarczy zmienić nazwę pliku ja teraz z pracy tego nie zrobię??

Prosze jak ktos znalazl rozwiazanie to niech podzieli sie informacja ze ok - sa dwa sposoby bridge.conf na mosquitto.conf albo debug w ustawieniach dodatku.

Zmiana bridge.conf na mosquitto.conf nie pomogla - dodatnie debug: true juz tak - teraz wszystko dziala.

Właśnie ta wersja weszła w marcowej aktualizacji (poprzednio był 2.0.11).

Jeśli chodzi o mostek, to mam go skonfigurowany (do innych celów) w pliku o dość losowej nazwie i działa.