HACS - Konfiguracja

Jestem w trakcie instalacji HACS. Mam problem - jak mam przerzucić ściągnięte pliki do folderu /config/custom_components/hacs? Działam na Windows 10.

Zainstaluj dodatek “Samba share” znajdujący się w Supervisior

Ok i co dalej? Zielony w tym jestem :wink:

Konfigurujesz go i masz w otoczeniu sieciowym normalnie widoczne katalogi z HA

Uzupełniasz konfig dodatku w pozycji username i password

workgroup: WORKGROUP
username: nazwa_użytkownika 
password: hasło
interface: 
allow_hosts:
  - 10.0.0.0/8
  - 172.16.0.0/12
  - 192.168.0.0/16
  - 'fe80::/10'
veto_files:
  - ._*
  - .DS_Store
  - Thumbs.db
  - icon?
  - .Trashes
compatibility_mode: false

Po uruchomieniu lub jak już uruchomiłeś po zrestartowaniu dodatku wpisujesz

 \\192.168.1.1\config

podajesz ustalony przed chwilą login oraz hasło. Oczywiście podajesz adres Swojego HA

Ok, udało się przekopiować. Na GitHub utworzyłem Token.
Niestety w Integracjach HA nie znajduję HACS… Co robię nie tak?

@dan0031 pokaż jak u Ciebie wygląda ścieżka do katalogu “hacs”.
Powinna być następująca:

config/custom_components/hacs/

i po drugie po skopiowaniu plików zrestartowałeś HA?

Wystarczy, że będziesz dokładnie postepować wg instrukcji na stronie:



a gwarantuję, że wszystko będzie działać za pierwszym razem, potwierdzone :slight_smile: .

Mimo to nadal mam problemy…

A integracja HACS się nie pojawia… :thinking:

A robiłeś według tego?

@artur Oczywiście, krok po kroku i integracja się nie pojawia niestety

Zrestartowałeś po przekopiowaniu plików HA?

Tak jest. Mam drobne problemy z HA bo ani nie widzi żadnych notify i z tym też mam problem. Pewnie ja coś robię źle ale to już siła wyższa :smiley:
ZIP który pobrałem rozpakowałem bezpośrednio w HA (korzystając z Samba share) i zipa usunąłem.

@dan0031 zbierz to wszystko to jutro jak się przetniemy to spróbujemy to wszystko ogarnąć

Temat rozwiązany dzięki Arturowi. W jakiś dziwny sposób niepoprawnie rozładował zip-a. Wszystko działa, dzięki @artur! :slight_smile:

Edit: Dodam jeszcze że musiałem zresetować malinkę na której mam postawione HA - poprzez wypięcie zasilania. To także wpłynęło na pojawienie się integracji HACS.

1 Like

Twój problem nie jest związany z HACS tylko z dodatkiem do HACS, lepiej będzie ja utworzysz nowy wątek w kategorii Home Assistant - Dodatki albo Integracje.

W takim razie proszę administratora o przeniesienie wątku do poprawnej kategorii.

Oszczędzaj czas administratorów, możesz to zrobić sam:

  • utwórz nowy wątek
  • skopiuj treść
  • wątek tutaj skasuj

Gotowe, mina z sukcesu - cenna :grin:

1 Like

OK, w porządku :slight_smile: Już przerzucam.

Witam i proszę o pomoc ,co robię nie tak ze pokazuje mi się ten komunikat ?? Czy muszę wpisywać gdzieś konfiguracje konta ??