Home asistant select tariff

idzie zmiana

Adopt SelectEntity in Utility Meter by dgomes · Pull Request #55690 · home-assistant/core (github.com)

The utility_meter tariff selector entities are now standard select entities with entity_id select.X instead of custom entities with entity_id utility_meter.X
In addition:

The service call utility_meter.select_tariff with argument tariff is deprecated in favor of service call select.select_option with argument option
The service call utility_meter.next_tariff is deprecated with no replacement
Backwards compatibility until HA Core release 2022.7:

The deprecated utility_meter.X entities are still available
The service call utility_meter.select_tariff still works on utility_meter.X enties, but a warning is logged when it's called
The service call utility_meter.next_tariff still works on utility_meter.X enties, but a warning is logged when it's called
In HA Core release 2022.7:

The deprecated utility_meter.X entities will no longer be available
The service call utility_meter.select_tariff will be removed
The service call utility_meter.next_tariff will be removed
What users need to do, before HA Core release 2022.7:

Update automations and UI and replace the no longer supported entity_id utility_meter.X with entity_id select.X
Update automations which change tariff by calling select.select_option and change the tariff argument to option

czy ktoś już ogarnia jak to zastosować w node -red ??
narazie mam jeszcze po staremu select_tariff, ale tego nowego zapisu nie ogarniam

automatyzacja w HA jest dla mnie zrozumiała:

automation:
  trigger:
    - platform: time
      at: "09:00:00"
      variables:
        tariff: "peak"
    - platform: time
      at: "21:00:00"
      variables:
        tariff: "offpeak"
  action:
    - service: select.select_option
      target:
        entity_id: select.daily_energy
      data:
        option: "{{ tariff }}"
    - service: select.select_option
      target:
        entity_id: select.monthly_energy
      data:
        option: "{{ tariff }}"

ale nie wiem jak to na node-red przeniść


EDIT:

już ogarnięte w Node Red

Wystarczy zmienić utility_meter.select_tariff na select.select_option, a agument na option

Mógłbyś zamieścić flow że zmiana taryfy bo kombinuje i lipa jest

Jestem na urlopie ale trzymaj export, może coś zdziałasz ja mam G13. Na telefonie źle się noda obsługuje.
flows.json (4,8 KB)

Hej, ja również mam problem z nowym UTILITY METER - automatyzacja nie przełącza taryf.
Na pierwszej maszynie korzystam z tej integracji bez problemu od ponad roku, chciałem ją zaimplementować w drugiej instancji, zapoznałem się z nową dokumentacją i poległem na automatyzacji przełączania taryf…
W narzędziach deweloperskich mam encję select.daily_energy która posiada opcje peak, offpeak i mogę je zmieniać. Jednak nie mogę wywołać takiej usługi: zarówno poprzez automatyzację jak i narzędzia deweloperskie. Po wprowadzeniu “tariff” w pole Option to select wyświetla się błąd “Unknown error”. Co ciekawe jeśli wpiszę w to pole wartość “peak” lub “offpeak” to działa i encja zmienia stan.
Kod wkleiłem ze strony dokumentacji, wiele tego nie ma …
Ktoś się z tym spotkał?

- id: '1639836291442'
  trigger:
  - platform: time
    at: 09:00:00
    variables:
      tariff: peak
  - platform: time
    at: '18:00:00'
    variables:
      tariff: offpeak
  action:
  - service: select.select_option
    target:
      entity_id: select.daily_energy
    data:
      option: '{{ peak }}'
  - service: select.select_option
    target:
      entity_id: select.monthly_energy
    data:
      option: '{{ peak }}'

spróbuj tak

service: select.select_option
data:
  option: poza_szczyt
target:
  entity_id: select.t_cup_dzienne_zuzucie_energii

w swojej automatyzacji usuń {{ }} znaki, bo to chyba skladnia nie taka

Z tym kodem taryfa przełączyła się na “offpeak”… ale nie o 6.00, tylko 8.00…

- id: '1639836291442'
  trigger:
  - platform: time
    at: 06:00:00
    variables:
      tariff: "peak"
  - platform: time
    at: '18:00:00'
    variables:
      tariff: "offpeak"
  action:
  - service: select.select_option
    target:
      entity_id: select.daily_energy
    data:
      option: "{{ tariff }}"
  - service: select.select_option
    target:
      entity_id: select.monthly_energy
    data:
      option: "{{ tariff }}"

UPDATE: po sugestii kolegi MarcinKD usunąłem klamry, zaskutkowało błędem wyświetlonym w logu automatyzacji : “option tariff is not supported by utility meter”. Zmieniłem
tariff na ofpeak i działa!
Tylko czy to oznacza że trzeba zrobić pojedyncze automatyzacje pea/offpeak dla każdej zmiany???