Kamera w HA - brak obrazu w karcie widoku

Uruchomiłem HA na RPi 4 i kamerę HikVision zgodnie z artykułem i filmem Artura “Dodajemy obsługę kamery”. Obraz kamery widzę w motionEye ale w interfejsie użytkownika w oknie widoku utworzonym na bazie “obraz encji” mam pusty ekran.
W integracji jest motionEye ale nieskonfigurowane. Przy próbie konfiguracji należy podać “nazwę użytkownika administratora” oraz “nazwa użytkownika podglądu” wraz z hasłami.
Nie mogę znaleźć miejsca do określenia tych użytkowników, poza tym nie wiem, czy faktycznie jest to konieczne.
Od kilku dni dopiero zajmuje się HA, więc moja wiedza jak widać jest podstawowa.

Administratora (admin) i użytkownika podglądu (user) konfigurujesz w motionEye tutaj:


nastaw się na dłuższą walkę, bo optymalne parametry pozostałych ustawień nie są łatwe do znalezienia i zależą od użytych kamer oraz ich ustawień (więc Cię czeka albo dogłębna lektura dokumentacji motion - nie mam na myśli motionEye - to jest tylko graficzna nakładka do motion, ale oczywiście i tą dokumentację warto przekopać, albo sporo eksperymentów, a jak znam życie to i jedno i drugie).

Skoro to kamera IP, to nie musisz jej podglądu konfigurować za pomocą motionEye (motionEye można wykorzystać do wykrywania ruchu, bądź jako rejestrator, można wprawdzie za jego pomocą zrobić transkoding ale nie polecam na słabym sprzęcie, choć w sumie chyba i tak najwięcej zależy od kodeka źródłowego).

Dzięki serdecznie za szybką reakcję. Faktycznie uzupełnienie danych 2ch kont uruchomiło 2 kamery i działają prawidłowo.
Na razie ustawienia podstawowe tzn, ilość klatek/s, rozdzielczość itd powodują, że kamery działają. Oczywiście jest do przepracowania temat wykorzystania możliwości reakcji na ruch, zapis na np. Synology ale to z czasem.

Szukam integratora kamer, otwierania bramy, furtki, innych przełączników i sterowania wszystkim z telefonu. W porównaniu z HomeBridge, openHAB to po 3ch dniach czytania o tej platformie wydaje się, że HA jest najciekawszym rozwiązaniem.

Też kiedyś miałem motion eye, ale zrezygnowałem, zżerał ponad pół procka

1 Like

Zależy jaki to procek.
motion_eye_csi_cam_Screenshot 2022-02-01 at 21-30-00 Poziomo – Home Assistant

T620 na 4 rdzeniach :thinking:

AMD GX-415GA czyli niby wszedł na rynek w 2013 i nawet jeszcze nie osiągnął EOL, ale jak znam życie to 15W “grzejnik bez wydajności”, który bez aktywnego chłodzenia throttluje cały czas (warto monitorować flaki komputera, by wiedzieć jak się sprawy mają, w tym zegar i temperaturę CPU, a nie tylko % obciążenia CPU).

A u mnie inny problem - w sieci lokalnej bez problemu wszystko pokazuje ale jak tylko zaloguje się z zew. widzę miejsce po kamrce ale nie obraz.