Openweather problem z API

Panowie mam duży problem.
Chciałem zainstalować integrację openweather i zacząć działać ze “statusem porannym”.
Podczas instalacji muszę podać API. Niestety wyświetla mi się komunikat, że jest on nieprawidłowy. Miał już ktoś podobny problem? Próbowałem wpisywać na różne sposoby - sam API, API z adresem i nic.
Dodam, że właśnie zaktualizowałem HA do 0.117

wpisałeś API zaraz po rejestracji na serwisie ? Bo mi to zaczęło działać po ok 24 godzinach od rejestracji

Również potwierdzam 0.117.1 i działa OK (również przed update było OK), prawdopodobnie trzeba poczekać na aktywację konta, jak wspomniał @Blazej

@szopen a działa już PL w wersji 117.1?

@pawelwaz bez zmian - przetłumaczona tylko jedna encja ze wszystkich związanych z OW

Dzięki za informację. Faktycznie bardzo długo musiałem czekać na aktywację API ale dzisiaj sprawdziłem i jest już OK

@artur dzięki a informację, na razie nie aktualizuję się bo wiem, że jest trochę błędów. Natomiast pytanie, czy Ty robiłeś coś w związku z brakiem przetłumaczenia (zmiany nazw czy też inna apka)?

@pawelwaz na razie zrobiłem najprostszą rzecz. wyłączyłem pogodę z powiadomienia. Jednak to rozwiązanie tymczasowe. Jeżeli w kolejnej wersji nie naprawią tego. Napisałem do nich w tym temacie. To wtedy dorobię mapowanie angielskich statusów na polskie i będzie spokój :smiley:

No to w takim razie poczekam jeszcze, może coś się w tej kwestii poprawi. Dzięki


nie bardzo wiem co miałoby być po polsku (ale nie używam prognozy - może tam jest coś o co pytasz)

@szopen tak są jeszcze inne encje, które są nie przetłumaczone. Jest przetłumaczona tylko jedna encja. Właśnie encje które są nie przetłumaczone wykorzystuje, pewnie jak większość do statusu porannego

Cześć, wrzućcie sobie tłumaczenie, narazie to wystarczy, puki aura nie przejdzie na zimową…:slight_smile:
tłumacz.json (1,4 KB)

3 Likes

Dobra robota, a miałem się za to zabierać w tym tygodniu. Dzięki, czas przeznaczę na coś innego.

Hej,
Mam problem z tym “statusem porannym” udało się zrobić pierwsza część, teraz stoję na pogodzie.
Zainstalowałem tego openweather, działa ale mam statusy po ANG, widzę, że też macie taki problem - to znaczy, że nic nie zepsułem :wink:
Pytanie teraz jak używać tych plików z rozszerzeniem .json - mam je gdzie wgrac do folderu jakiegoś? Lub może mam pobrać jakiś plik to odtworzenia?
Proszę o pomoc :slight_smile:

z prawej =>menu=>import=>na środku selected a file to import=> wybierasz plik *.json

jak są jakieś encje to musisz edytować każdą i serwe ha ustawić na swój

do mojego tłumaczenia dopiszcie fog=>mgła

Macie źródło wszystkich statusów jakie mogą być w openweathermap a idą do HA?
Ja znalazłem Weather Conditions - OpenWeatherMap ale dzisiaj mam w HA status “snowy-rainy” czego nie znalazłem na liście. Jest za to “Rain and snow”. Zabieram się za tłumaczenie. Zrobiłem protezę ale trudno wszystko przewidzieć.
image

Ja wklepałem, te które się pojawiają u mnie. Te które udostępniłeś to jeszcze się u mnie nie pojawiły.

:slight_smile: Jak już zrobisz to chętnie skorzystamy z gotowca. Chociaż wydaje mi się, że nie wszystkie występują, ale mogę się mylić.

dobrze, dobrze, niech wszyscy dopisują nowe stany, to szybciej ogarniemy tłumaczenie

Hej,
pozwoliłem sobie zaimportować cały proces. Na razie wyłączyłem pogodę, jednak gada mi po angielsku ( datę i dojazd do pracy) Co mam zmienić, aby zmienić na “ludzki” język:)