Problem ze sterowaniem LG webos za pomocą HA

, ,

Cześć
Mam tytułowy problem
Prawie wszystko działa, oprócz || pauzy i włączania. Szukałem rozwiązania na forach, lecz nic konkretnego nie znalazłem.
Screenshot_17
Screenshot_18

A masz w ustawieniach tv włączony WoL?

Nie widzę tego w opcjach.



Podaj model , to popatrzę w instrukcji, LG odpalałem u znajomego (sam mam zdecydowanie inny) i nie pamiętam wszystkich kruczków.

Wol to podobno LG Connect App, ale mnie też nie działa.

To brzmi sensownie, sprawdzałeś włączanie z poziomu ich aplikacji (są przynajmniej 2 które powinny działać z większością modeli)?

Oprócz tego podejrzane jest oszczędzanie energii (ale nie pamiętam czy akurat w LG to powoduje wyłączenie kart sieciowych).

Model tv
LG 55EG910V

Niestety LG nas olało

Mam Aplikacje Lg ThinQ, ale tam nie widzę żadnych informacji

Jakkolwiek miałem właśnie pisać - jeśli któraś z tych aplikacji działa poprawnie to i integracja też powinna (co do tej drugiej pewności nie mam, być może chodzi o tą którą wspomniałeś - ma ona przecież włączanie TV z aplikacji?)

Model 60LF592V z aplikacji Lg TV plus nie da się włączyć. Sprawdzałem z wyłączonymi funkcjami Eco i oszczędzania energii. pozostałe funkcje działają, również w HA. Włączanie odpuściłem bo Tv ma ze 6 lat, być może to nie działa. Aplikacja była potrzebna jak pilot “sam się zalał”.

Te aplikacje, są jedynie do sterowanie jako pilot nie widzę tam jakiś ustawień tv. Są tam takowe?

Ja nawet takiej aplikacji nie mam w sklep play :sweat_smile:

@mitaks edytuj posty - nie pisz jednego pod drugim

Nie chodzi o ustawienia w aplikacji, tylko o “guzik” do włączenia TV - jeśli on działa w aplikacji to teoretycznie musi działać też w integracji, a ustawienia TV masz w samym TV.
Oczywiście twój model może przypadkiem nie obsługiwać włączania po sieci i dlatego zaproponowałem akurat te apki żebyś mógł sprawdzić WoL (bo miałem je kiedyś zainstalowane na swoim telefonie i wygrzebałem je ze swojego konta, ale od popołudnia nic się nie zmieniło - wciąż w domu nie mam TV LG, więc osiągnęliśmy granicę tego w czym mogłem pomóc).

U mnie w telewizorze innego producenta opcje WoL są po prostu w tym kawałku menu powiązanym z siecią (ale by działało poprawnie musi być aktywne “szybkie włączenie zasilania” które jest ukryte w ustawieniach zaawansowanych, w przeciwnym razie TV wyłącza kartę sieciową i nici z włączania za pośrednictwem sieci).
W LG u znajomego jakoś ogarnąłem która funkcja z czym jest powiązana, ale naprawdę nie pamiętam szczegółów (zwykle wygodniej mieć do tego włączone angielskie menu, bo polskie wersje są czasem tłumaczone w dziwny sposób).

Zobacz w menu TV Sieć > LG Connect Apps

Niestety żadna z tych aplikacji nie działa, znaczy działa lecz nie mogę uruchomić tv ze spoczynku.

Wniosek - albo jakieś ustawienie powoduje, że po wyłączeniu TV nie przechodzi do stanu stand-by z włączoną kartą sieciową (co jest konieczne do działania WoL), albo twój model nie ma takiej możliwości (raczej dziwne).

PS w aplikacji masz nieustawiony MAC-adress TV, więc nie może ona wysłać “pakietu magicznego” (czyli nie wysyła żądania WoL).

A teraz wróćmy na początek - w konfiguracji integracji nie podałeś MAC-adresu (myślałem, że to po prostu powszechna maniera zamalowywania istotnych do rozwiązania problemu informacji).

Znasz MAC swojego TV?

A próbowałeś podać Mac w innym formacie?
Komputer mam :thinking:

  - platform: wake_on_lan
    mac: "38-D5-47-B2-47-4C"
    name: computer

A bramka Xiaomi

mac: 7C49EB9320F4

Broadlink

mac: 64:EA:34:C7:B6:F1

Tak mam to zrobione. Zmienić coś?
Screenshot_6

Na moje oko to nie wiem skąd wyczesałeś ten MAC, ale on pasuje do Espressif Inc. (smart-gniazdko?, masz coś na ESP?), a nie do LG.

Umiesz sprawdzić MAC swojego TV?

Uprzedzę kolejne kroki

  1. fajne narzędzie okienkowe dla Windows (wbrew nazwie skanuje też połączenia przewodowe)
    Wireless Network Watcher - Show who is connected to your wireless network

  2. jak już go ustalisz to podaj w apce i przetestuj (format zapisu może być inny, z dwukropkami, myślnikami lub bez)

Tak mam sonoffy. Zły adres skopiowałem :man_facepalming:

Nadal jest brak reakcji :confused:

# Example configuration.yaml entry for a TCP connection
# Example configuration.yaml entry
wake_on_lan: # enables `wake_on_lan` integration

webostv:
- name: Living Room TV
  host: 192.168.0.14
  #other settings
  turn_on_action:
    service: wake_on_lan.send_magic_packet
    data:
      mac: C8:08:E9:9E:71:9C
      broadcast_address: 192.168.0.255

  customize:
    sources:
      - cda.pl
      - netflix
      - youtube
      - przeglądarka
      - hdmi1
      - hdmi2
      - hdmi3

media_player:

notify: