Wmbusmeters (W-MBus to MQTT) jako addon Supervisora

Pojawiła się możliwość instalacji mbusmeters jako dodatku supervisiora.
Wystarczy w supervisiorze w “Sklepie z dodatkami” dodać następujące repozytorium:

https://github.com/weetmuts/wmbusmeters
2 Likes

Jakby ktoś miał problemy z zainstalowaniem jako addon Supervisora
Screenshot - 20.09.2021 , 15_10_57

Moj System operacyjny to:  
Debian GNU/Linux 10 (buster)

ale pewnie na innych wspieranych systemach
bez aktualizacji docker będzie to samo

To trzeba zaktualizować system

sudo apt-get update
sudo apt-get upgrade

The following packages will be upgraded:
containerd.io docker-ce

inaczej wyskakują błędy:
1 Like

Witam Wszystkich, Panowie a ja mam taki problem z tym addonem w postaci takiej że nie mogę utworzyć sensora z danymi, niby dodatek mam zrobiony poprawnie, bo otrzymuję dane, plik z danymi się zapisuje itd, ale nie mogę utworzyć sensora z danymi:
mój konfig nakładki:

data_path: /config/wmbusmeters
conf: |-
  loglevel=normal
  device=rtlwmbus
  donotprobe=/dev/ttyAMA0
  listento=c1,t1,s1
  meterfiles=/config/wmbusmeters/logs/meter_readings/
  meterfilesaction=overwrite
  logtelegrams=true
  format=json
  logfile=/config/wmbusmeters/wmbusmeters.log
  shell=/wmbusmeters/mosquitto_pub.sh wmbusmeters/$METER_NAME "$METER_JSON"
meters:
  - |-
    name=MainWater1
    driver=auto
    id=00238332
    key=00000000000000000000000000000000
mqtt:
  host: 192.168.x.xx
  port: 1883
  user: xxx
  password: xxx 

w pliku sensor.yaml

  - platform: mqtt
    state_topic: "wmbusmeters/MainWater1"
    json_attributes_topic: "wmbusmeters/MainWater1"
    unit_of_measurement: "m3"
    value_template: "{{ value_json.total_m3 }}"
    name: "czujnik ciepła woda"
    icon: "mdi:gauge"

System operacyjny: Home Assistant OS 6.4
Wersja Core: core-2021.9.7
w windowsie za pomocą mqtt explorer , mam podgląd czy dane są wysłane i widze ,że wszystko jest ok
wmbusmeters

MainWater1 = {"media":"water","meter":"apator162","name":"MainWater1","id":"00238332","total_m3":162.144,"timestamp":"2021-09-21T14:23:14Z","device":"rtlwmbus[00000001]","rssi

a dlaczego na home assitant nie działa? mam systemowy mosquito broker ustawiony

Nie wiem czy dobrze formatuje się kod który wkleiłeś ale mqtt nie jest w meters: tylko osobno poniżej
image

mam tak jak Ty, źle się wkleiło

“samo” się nie wkleja - musisz użyć formatowania (tak, jak zedytowałem twojego posta), użyj linijek z ```
(to odwrotne apostofy spod klawisza tyldy)

Na moje oko to masz za głębokie wcięcie w sensor.yaml (takie jak masz by było dobre gdybyś to wrzucił do configuration.yaml) edit: nie trafiłem :stuck_out_tongue_winking_eye:

- platform: mqtt
  state_topic: "wmbusmeters/MainWater1"
  json_attributes_topic: "wmbusmeters/MainWater1"
  unit_of_measurement: "m3"
  value_template: "{{ value_json.total_m3 }}"
  name: "czujnik ciepła woda"
  icon: "mdi:gauge

zrobiłem tak i dalej nie ma sensora, już ręce mi opadają z tym , inne sensory dodawały się ok a z ten coś nie idzie

W HA w " MQTT settings" nasłuchuj poniższy temat:

wmbusmeters/#

zobaczysz czy dane docierają do Twojego HA.

Wiadomość 0 otrzymana w wmbusmeters/MainWater1 o godzinie 19:28:
{
    "media": "water",
    "meter": "apator162",
    "name": "MainWater1",
    "id": "00238332",
    "total_m3": 162.164,
    "timestamp": "2021-09-21T17:28:45Z",
    "device": "rtlwmbus[00000001]",
    "rssi_dbm": 140
}

czyli działa, dane są

dla testu daj ten parametr jako:

value_template: '{{ value_json["total_m3"] }}'

już wiem co było nie tak ostatnio jak robiłem porządki w plikach i między innymi plik sensors.yaml, przeniosłem do folderu i zrobiłem include, a starego pliku w głównym folderze nie usunąłem :slight_smile: i cały czas edytowałem stary plik :D, teraz jest już ok , gapa ze mnie sorrki, ale dziękuję za pomoc, ale jeszcze jedna sprawa , co trzeba wpisać w configu w wmbusmeters, aby z czytywał dane np od godz 22 do 23 każdego dnia?

wmbusmeter korzysta z rtl_433 albo rtlwmbus, czy oprogramowanie do tego da się skompilować i zainstalować na Home Assistant Core (gotowy obraz dla RPi)?

@macek - masz jeszcze bramkę nr.2 czyli pominąć oprogramowanie rtl i kupić dongla sprzętowego.
Najtańszy kosztuje około 150 PLN ( nie mylić z tymi do RTL-SDR) na Amazonie.

Jak masz Linuksa to da się - wystarczy że do crona wpiszesz wywołanie usługi o 22 a o 23 zatrzymanie.
Samo polecenie wmbusmeters ma parametr --exitafter=<time> i time podajesz w minutach czy s.
I jest jeszcze coś takiego w składni : --reopenafter=<time> close/reopen dongle connection repeatedly every <time> seconds, eg 60s, 60m, 24h

Nie znalazłem niczego co wspiera Wireless M-Bus w tej cenie, jest jeszcze iM871A-USB i NANO-CUL (mbus) 868. O jakim urządzeniu piszesz?

NanoCul właśnie - tylko trza mu firmware zmienić na właściwy.

To zaś zabawa i odkrywanie na nowo.

Odbiornik
Ponieważ z bezprzewodowym M-BUS nie miałem do czynienia najpierw należało się zaopatrzyć w jakiś odbiornik. Ogólnie są trzy rozwiązania:
- dedykowany odbiornik wireless M-BUS np. iM871A-USB (należy sprawdzić te urządzenia na stronie projektu wmbusmeters)
- układ typu CUL (właściwie nanoCUL) – konstrukcja oparta o Arduino Nano z układem FTDI i odbiornikiem CC1101
- układ oparty o odbiornik DVB-T

To ostatnie rozwiązanie jest najtańsze, jednak dekodowaniem sygnału musi zajmować się procesor komputera. Planowałem podłączenie układu do Pi i wolałem go nie męczyć takimi rzeczami, tym bardziej, że realizuje już inne funkcje (odbiór i dekodowanie temperatury z serii czujników INODE BT).
Rozwiązanie pierwsze wygląda na najprostsze, ale zdziwiła mnie cena tych odbiorników (ponad 300zł). Zdecydowałem się na rozwiązanie środkowe – nanoCUL. Jego zaletą jest zewnętrzna antena. Zakup na ebay był bezproblemowy:
Zdalny odczyt licznika wody z nakładką IZAR
Są też dostępne trochę tańsze wersje bez obudowy. Niestety, jak się później okazało ten odbiornik nie działa właściwie z wmbusmeters – ma inny firmware. Na stronach często jest informacja o możliwości wgrania odpowiedniego firmware do MBUS, czego wcześniej nie doczytałem. Na całe szczęście na stronie: Link jest firmware nanoCUL-MBUS.hex, który można pobrać i za pomocą XLOADERa Link wgrać.

Odczyt za pomocą NanoCUL na RPi

Przetestowałem ten dodatek więc pare słów dla innych :
Test odbył się na czystym HA , czas instalacji około 15 minut.
Konfiguracja prosta, niestety nie współpracuje z licznikiem Tauron jakby ktoś chciał sobie zastosować.
Addon zawiera w sobie zarówno rtl_433 jaki rtlwmbus - kwestia zmiany wpisu w pliku config.
Ponieważ nie mam innych urządzeń - nie mogę się wypowiedzieć.

Moje spostrzeżenia po miesiącu używania addona Wmbusmeters (W-MBus to MQTT) version : 0.2.19 wraz z dongle DVB-T RTL2832U R820T2 na RPi3+:

  • dodatek używa sporo CPU, co było do przewidzenia:
    image

dlatego w samym HA jest to również zauważalne:

  • wzrost Processor use z 8% do 35%,
  • wzrost CPU temperature z 55°C do 71°C (+16°C).

Wszystko jednak działa stabilnie i bez problemów.

1 Like