Wmbusmeters i FLOWIS+

Dzień dobry,

czy ktoś z Państwa spotkał się z nakładką radiową FLOWIS+ na wodomierz? O ile z odczytaniem danych z Apatorów nie mam problemów, tak z tym wynalazkiem nie mogę sobie dać rady.
W sieci nie znalazłem żadnej dokumentacji do tego urządzenia, która mogłaby coś podpowiedzieć.

1 Like

jakieś zmiany w temacie? Też szukam jak dobrać się do tego wodomierza

Macie jakieś ramki odebrane rtl’em albo poprzez cc1101?
Coś tam w necie się przewija że nadają na 868MHz.

Dołączam się do tematu. Też mam tą nakładkę. Coś ktoś wie czy da się to zintegrować z HA?

Product overview strona produktu na stronie producenta, https://play.google.com/store/apps/details?id=pl.globalrnd.libra.LibraRS&hl=pl&gl=US aplikacja, System zdalnego odczytu wodomierzy LibraRS informacje o aplikacji i przystawce pomiarowej.

Z tego PDFa:

  • compatible to OMS
  • C1/T1 Mode
  • Radio transmission frequency: 868 MHz

Wygląda obiecująco, z daleka pachnie wM-Bus - ale…
Możliwe że istnieje parę wersji tego radia. Chyba gdzieś mieliśmy info że to nie jest do końca wM-Bus.

Najlepiej samemu spróbować odebrać ramkę (albo tunerem albo CC1101). Jak coś odczyta to potem już tylko

Możesz podesłać zdjęcie Twojej nakładki? Może jakieś ciekawe oznaczenia tam są?

Nakładkę Flowis+ próbowałem odczytać za pomocą modemu DVBT na różnych zakresach częstotliwości [od 868.00 do 869.90 ]
Żadnych komunikatów, myślałem że jest martwy,
Pan który odczytuje dane dla wodociągów powiedział mi iż oni mają 5 różnych czytników wodomierzy. Kto wygra przetarg na wodomierze ten daje im czytnik za free.


Ja rozwiązałem to zakładając szeregowo drugi mój wodomierz z nakładkami apatora 162, działa to rewelacyjnie,
Korzystam z ESP i pracy @_Szczepan, modem DVBT poszedł w odstawkę,

W poprzednim poscie był link do nakładki obłej ta jest kanciasta. Obstawiam że to inne modele itp. Może tak być że pod jedną nazwą mają różne technologie (w zależności od rocznika :wink: ).

Moim zdaniem warto by było mieć jakiś wątek z zdjęciami i opisem czym można odczytać daną nakładkę.

Próbowałem i nic nie czyta, tak jak pisałem myślałem że martwa, ale spółka wodna odczytuje.
Są różne nakładki
Link do karty katalogowej https://metering.com.pl/wp-content/uploads/2019/11/moduły-radiowe-FLOWIS.pdf
Jest napisane 868Mhz ale tylko tyle :frowning:
image

Cannot find driver for mfct: (FLM) Unknown (0x198d) type: Heat meter (0x04) ver: 0x01 and type: Water meter (0x07) ver: 0x01 · Issue #713 · wmbusmeters/wmbusmeters · GitHub moja jest dokładanie taka jak ta użytkownika zdzichu - w sensie występuje pod nazwą flow meters moduł radiowy OMS. Różni się wersją (1.12.7), datą produkcji i oczywiście IDkiem. Na mojej instalatorzy nie zanotowali nic (numeru lokalu jak pisze zdzichu) na naklejce. Jestem w stanie podsłuchać jakieś kmunikaty po wmbusmeters, ale na szybko nie jestem w stanie określić czy nie łapię liczników sąsiadów - większość telegramów jest błędna lub zaszyfrowana. Po majówce mogę się postarać podrzucić jakieś logi.

Edited: Namierzyłem jeden z moich liczników na szybko przeglądając logi. Figuruje jako zaszyfrowany watermeter, nieznanego producenta. Także niestety wszystko wydaje się sprowadzać do pozyskania kluczy w pierwszym kroku.

Szyfrowanie mnie nie dziwi bo według specyfikacji producenta wprowadzili to w trybie C1, oraz widziałem kilka wpisów o tym mówiących. Obawiam się że legalne pozyskanie kluczy może być niemożliwe.

Hej, u mnie np jest taka nakładka

Masz wśród znajomych jakiegoś dobrego prawnika?
Powołując się na dyrektywę EED osoba uprawniona będzie mogła uzyskać klucz.

Aktualnie mój wmbus tylko T1 odczyta. Może po długim weekendzie też C1 dodam.

edit [11.2023]
C1 też coś tam potrafi już odczytać - ale to ciągle wersja beta (brak kontroli CRC)

edit [02.2024]
C1 A oraz C1 B już są możliwe do odczytu od wersji 3.0.0

Istotny update dla wszystkich zainteresowanych odczytem radiowym z nakładek FLOWIS. :wink:

Merbanan ogarnął dostarczone przez użytkowników logi z nasłuchu nakładek i zaimplementował ich obsługę w rtl_433. Sprawdziłem, działa dla nakładek z numerem seryjny 2403 i 2404 w wersji 24.8.00. Podobno datagramy z nowszych 2405 są szyfrowane, więc trzeba na to jeszcze poczekać.

Co ważne, te nakładki wydają się nadawać tylko w określonych dniach i godzinach. W nocy jest cisza i teraz w weekend również. Więc trzeba się uzbroić w cierpliwość, żeby ten sygnał “złapać”. No i takie ograniczenie nie pozwala na bieżące monitorowanie zużycia, ale z drugiej strony - lepsze to niż nic.

1 Like

Czy jakoś specjalnie należy rtl_433 wywoływać? Wydawało mi się, że powinno zadziałać:

rtl_433 -v -R 237 -f 868M -s 1000k -F log

Ale przez dwa dni nic nie złapało.

Uruchomiłem rtl_433 na rpi.

pi@raspberrypi:~ $ rtl_433 -v -R 237 -f 868M -s 1000k -F log
rtl_433 version 23.11-41-g06b03b7a branch master at 202402051043 inputs file rtl_tcp RTL-SDR

New defaults active, use "-Y classic -s 250k" if you need the old defaults

Protocols: Registered 1 out of 251 device decoding protocols [ 237 ]
Input: The internals of input handling changed, read about and report problems on PR #1978
SDR: Found 1 device(s)
SDR: trying device 0: Realtek, RTL2838UHIDIR, SN: 00000001
FIR Filter 2400 kHz
Found Fitipower FC0012 tuner
SDR: Using device 0: Realtek, RTL2838UHIDIR, SN: 00000001, "Generic RTL2832U OEM"
Exact sample rate is: 1000000.026491 Hz
SDR: Sample rate set to 1000000 S/s.
Input: Bit detection level set to 0.0 (Auto).
SDR: Tuner gain set to Auto.
Input: Reading samples in async mode...
SDR: Tuned to 868.000MHz.
Allocating 15 zero-copy buffers
Baseband: low pass filter for 1000000 Hz at cutoff 200000 Hz, 5.0 us

Czy tak powinno wyglądać oczekiwanie na pakiety?

Tak, wygląda to prawidłowo.
A jak chcemy mieć podgląd działania oprogramowania rtl_433 przez przeglądarkę, to wpisujemy w komendzie uruchomienia dodatkowo argument -F http
Port dla WebUI to 8433

1 Like

Dzięki @angler !! Odpaliłem i działa odczyt z liczników flowis+ 2405 v24.8.00

1 Like

Mam problem z wystawieniem danych przez mqtt. Moja linijka wygląda tak:

rtl_433 -v -R 237 -f 868M -s 1000k -F http “mqtt://xxx.xxx.xxx.xxx:1883,user=mqtt_user,pass=pass,events=rtl_433[/model][/id]”

W odpowiedzi otrzymuję komunikat “event not found”
Co robię źle??

PS.: Dodam, że rtl_433 uruchomiony jest na rpi, na którym nie ma zainstalowanego HA.