Supla na Home Assistant dwa sposoby

Szanowni,

Ponieważ miałem troszkę problemu z przepięciem urządzeń SUPLA z brokera natywnego SUPLA na MQTT rodem z HA, a większość komentujących mówiło “Supli nie mam, nie pomogę”, to pozwolę sobie opisać co i jak w końcu udało mi się zrobić. Może komuś się przyda.

Mamy dwa sposoby podłączenia Supla do HA: oba przez MQTT, ale pierwszy opiera się na brokerze wbudowanym w serwer Supla, drugi to Mosquitto Broker z HA. Oba działają dobrze, ale jeśli w HA używamy także innych niż SUPLA urządzeń obsługiwanych przez MQTT - broker SUPLA się nie przyda. I wtedy właśnie pojawia się kłopot by to przełączyć…

Zacznijmy jednak od początku, sposób pierwszy, łatwiejszy - broker SUPLA.

  1. Musisz mieć konto na serwerach SUPLA (cloud.supla.org), ale to oczywiste jeśli używasz ich sprzętu.

  2. Po zalogowaniu się na serwery supla wybierasz w menu Konto->integracje, ostatnia zakładka Broker MQTT

  3. Klikasz “włącz” i kopiujesz wygenerowane informacje, czyli serwer (host), nazwę użytkownika i hasło brokera. Uwaga, hasło skopiuj i zapisz od razu, potem nie da się go już odczytać, możesz tylko wygenerować nowe. Tyle w SUPLA.

  4. W HA w configuration.yaml dodajesz następujący wpis:

mqtt:
  broker: TU_ADRES_SERWERA SUPLA
  port: 8883
  certificate: auto
  username: ID SKOPIOWANE Z SUPLA
  password: HASŁO SKOPIOWANE Z SUPLA
  discovery: true
  1. Zapisujesz, restartujesz HA, działa. W panelu integracje pojawi Ci się integracja MQTT opisana jako configuration.yaml, w niej twoje urządzenia i przypisane im encje.

A teraz co, jeśli trzeba zmienić to na broker z HA (lub od razu chcesz to u siebie), czyli sposób 2.

  1. Jeśli masz w HA podłączenie z brokerem SUPLA opisane powyżej - usuń wpis w configuration.yaml i usuń integracje z panelu integracji, który tym wpisem utworzyłeś. Samo usunięcie wpisu w configuration nie wystarczy. Zrestartuj HA.

1a. jeśli nie masz połączenia i od razu robisz to na Mosquitto - wykonaj punkty 1-3 z pierwszego sposobu.

  1. Uruchom w HA supervisora i w sklepie z dodatkami wyszukaj i zainstaluj Mosquitto Broker.

  2. Zanim uruchomisz po zainstalowaniu dodatku przejdź do konfiguracji.

  3. w username wpisz sobie jakiegoś użytkownika. Chyba nie ma znaczenia co tu wpisujemy

  4. W password: podobnie, jakieś hasło.

  5. Dopisz do konfiguracji:

customize:
  active: true
  folder: mosquitto

To ważne, bo tylko dzięki temu mosquitto przeczyta nasze wpisy z supli. Zapisz konfigurację.

  1. Teraz trzeba stworzyć właściwy katalog i plik konfigurujący most między SUPLA a mosquitto. Jak ktoś zna unixa, to zapewne wejdzie sobie w terminal SSH (też go trzeba zainstalować jako dodatek w Supervisorze) i komendą:

mkdir -p /root/share/mosquitto

założy katalog a potem założy w nim plik bridge.conf (nano bridge.conf) i wpisze do niego:

connection bridge-COŚ_TU_WPISZ (8-16 przypadkowych znaków, to będzie supertajny identyfikator połączenia)

address TU_ADRES_SUPLI_TAKI JAK_POPRZEDNIO:8883
topic supla/# in
topic homeassistant/# in
topic supla/+/devices/+/channels/+/execute_action out
topic supla/+/devices/+/channels/+/set/+ out
remote_username UŻYTKOWNIK_PRZEPISANY Z SUPLI
remote_password HASŁO_PRZEPISANE Z SUPLI
bridge_capath /etc/ssl/certs

Ja zrobiłem to bardziej leniwie i za pomocą SAMBY (także jako dodatek w Supervisorze) połączyłem się z Windowsa do serwera HA i w katalogu share założyłem prześliczny katalog mosquitto (taki jak w konfiguracji mosquitto brokera dodaliśmy w sekcji customize), oraz zwykłym notatnikiem utworzyłem w nim plik bridge.conf z zawartością jak powyżej.

Zapisuję plik (trzeba uważać na nazwę, notatnik windows ma tendencję do dodawania od siebie rozszerzenia .txt, trzeba je usunąć. Ma być bridge.conf

Teraz można uruchamiać lub zrestartować jeśli już działa Mosquitto Brokera. JA po tym jeszcze zrestartowałem HA, ale nie jestem pewien, czy potrzeba. Jeśli się nie pomyliliśmy, jeśli mamy usuniętą do spodu poprzednią integrację - SUPLA znowu zaczyna działać, urządzenia i encje mają te same nazwy, integracje działają, my się cieszymy. Jeśli ktoś nad tym pracował tak jak ja dłużej, może wykrzyknąć: “Mam Cię k… chu…!!!” Pomaga, sprawdziłem.

W sumie tyle.Tekst sformatowany

5 Likes

Nie trzeba mieć Supli żeby rozwiązywać problemy z Mosquitto broker, nigdy nie miałem Supli a integrację z Suplą udało się uruchomić - SUPLA => Supla-mqtt-client => MQTT => Home Assistant - #14 przez macek.

Nie, nie trzeba.

Zatem brawo Ty.
Ja mam, więc początkowy brak umiejętności bardziej złościł… :wink:

Witam kupiłem sobie LIcznik energi supli mew 01 i nie mogę się z nim połączyć a próbuje jak w tym poradniku .https://drive.google.com/file/d/10HTT6juRks7OcmRl10u9WWjwdMPKQwb3/view

Cześć!

Kilka miesięcy temu zakupiłem MEV-01 i zintegrowałem sposobem pierwszym, czyli przez cloud SUPLA. Teraz staram się dodać bramkę ZIGBEE (CONBEE2) przez ZIGBEE2MQTT ad-on. Niestety nie udało mi sie to. Moje podejżenie pada na integrację MEV-01.

Tyle kontekstu, a teraz pytanie: Czy druga metoda integracji pozwoli na uruchomienie dwóch klientów MQTT (publisher) w HA?

Trochę mylisz pojęcia, dodatek (add-on) Mosquitto broker służy do integracji HA z wszystkim co pozwala na komunikację po MQTT, np. Tasmota, Zibgee2MQTT itd. Wtedy możesz chmurowy broker MQTT zintegrować z lokalnym Mosquitto brokerem na swoim HA. HA może być zitegrowany tylko z jednym brokerem MQTT. Żeby dodać Zigbee2MQTT musisz najpierw usunąć z konfiguracji cloud broker MQTT Supli, zainstalować i skonfigurować Mosquitto broker, to juz było na forum poszukaj i tam zgłoś ewentualne problemy. Ten wątek dotyczy integracji Supli z Mosquitto brokerem.

Witam grupę.
No i ja walczę z suplą wariantem drugim bo powoli będę przechodził z całością do HA no ale no niby po kilku próbach zadziałało ale tylko śladowo.
Bo w HA pojawiły się stany urządzeń ale już z poziomu HA nie mogę ich zmienić co więcej nawet jak w supli zmienię to już stan w HA się nie zmienia.

w logach mosquitto:
1660637848: Client local.core-mosquitto.bridge-edfghjklcdsfgb closed its connection.
1660637879: Connecting bridge (step 1) bridge-edfghjklcdsfgb (xxx.supla.org:8883)
1660637879: Connecting bridge (step 2) bridge-edfghjklcdsfgb (xxx.supla.org:8883)
1660637879: Connection Refused: not authorised

więc skąd urządzenia skoro nie jestem autoryzowany

Skoro pojawiły się urządzenia to przynajmniej raz musiałeś się poprawnie zalogować do brokera MQTT Supli, proces logowania to zawsze dwa procesy: autentykacja (potwierdzenie, że Ty to Ty) oraz autoryzacja (sprawdzenie do czego Ty masz dostęp).

No ok to w takim razie urządzenia przy poprawnym zalogowaniu powinny w HA być aktywne, no i są ale próba zmiany ich stanu już się nie udaje. Sa aktywne nawet pomimo ciągłego błędu 1660640768: Connection Refused: not authorised

Autentykacja przebiegła poprawnie więc urządzenia się pokazały ("no i są) ale nie możesz nimi sterować (“ale próba zmiany ich stanu już się nie udaje”) bo autoryzacja nie działa. Proponuję wyłaczyć integrację brokera w chmurze Supli, wylogować się z chmury, zalogować się ponownie do chmury Supli i ponownie właczyć integrację, powinno się wygenerować nowe dane integracji MQTT.

Ok po wyłączeniu w cloudzie brokera urządzenia w HA nadal były widoczne czyli logowanie do clouda było cały czas ok? po odczekaniu chwili (bo od razu nie pozwolił włączyć ponownie brokera) broker został uruchomiony HA zrestartowane. a tak swoją drogą to gdzie należy podać hasło wygenerowane przez brokera w cloudzie bo to mi spokoju nie daje może tu robię błąd.

Tego się nie spodziewałem, i jak tu diagnozować problemy jak ktoś nie robi wszystkiego zgodnie z instrukcją, proszę przeczytaj jeszcze raz wszystko dokładnie (proponuję wydrukować i skreślać co się zrobiło): Integracja z Home Assistant (MQTT).pdf - Dysk Google.
Dodatkowo Supla na Home Assistant dwa sposoby.

@szopen proponuję ten wątek już zamknąć bo trochę wprowadza w błąd. Dyskusja powinna toczyć się w ramach wątku “Supla na Home Assistant dwa sposoby”.

Cóż okazuje się, że jestem głąbem. Ale tylko połowicznym bo na samym początku tak właśnie robiłem i nie działało po podaniu danych logowania do clouda przynajmniej była jakaś reakcja. Dziwne dopiero po “restarcie” brokera supli ruszyło jak trzeba. Złośliwość ze skreślaniem wybaczam :wink: bo końcowo zaczęło działać. Bardzo dziękuję. za pomoc i cierpliwość.

No bez przesady :slight_smile:, każdy popełnia błędy.

To nie złośliwość tylko najlepszy sposób jak się robi coś wg instrukcji a po raz kolejny raz nie wychodzi, skreślanie pozwala wyeliminować błędy pomijania kroków w instrukcji.

2 Likes

Przeniosłem fragment rozpoczęty przez @SzymaneK stamtąd tutaj, mam nadzieję, że to wystarczy dla czytelności dyskusji (to takie info dla czytających).

hmmm…niby działa u mnie ale nie zawsze :frowning:
uruchomiłem połączenie z supla cloud w moim HA i urzadzenia pokazywały sie bardzo ładnie ale …około poczatku sierpnia (lub lipiec ?) 2022 przestało działać . teraz po restarcie dodatku mosquito broker zaczyna działać ( czyli odczytuje kilka czujników temp i Mew-1 ) ale po godzinie znowu cisza.
… i ta cisza potrafi trwać dniami az ponownie zrestartuje dodatek brokera w HA.
co sie zmieniło ze mam taki kłopot ?
czy warto wyrzucić wszystko z HA i od nowa łaczyc sie z Supla ? - którą metodą ?

mi to nie działą :frowning:
dodałem
mqtt:
broker: mqtt4.supla.org
port: 8883
certificate: auto
username: z supli
password:z supli
discovery: true

w logach mam

Logger: homeassistant.components.mqtt
Source: helpers/config_validation.py:831
Integration: MQTT (documentation, issues)
First occurred: 17:52:04 (5 occurrences)
Last logged: 17:52:04

  • The ‘broker’ option near /config/configuration.yaml:58 is deprecated, please remove it from your configuration
  • The ‘discovery’ option near /config/configuration.yaml:58 is deprecated, please remove it from your configuration
  • The ‘password’ option near /config/configuration.yaml:58 is deprecated, please remove it from your configuration
  • The ‘port’ option near /config/configuration.yaml:58 is deprecated, please remove it from your configuration
  • The ‘username’ option near /config/configuration.yaml:5
    Screenshot_20220928_180026
    8 is deprecated, please remove it from your configuration

mqtt jest jako wykryte ale nie skonfigurowane

jak dam skonfiguruj to mowi ze nie dziala

a sory - zadziałało - portu nie zmieniłem ale przez konfiuguracje nie jak w watku -ale z panelu jest ok

Aktualnie integracja z brokerem MQTT jest dostepna tylko przez GUI - MQTT - Home Assistant. Skasuj to co dodałeś w pliku configuration.yaml i dodaj przez GUI.

1 Like

Nie wiem jak u innych, ale ja jako “address” w pliku bridge.conf musiałem podać svrXX.supla.org z tej pierwszej zakładki na stronie SUPLA Cloud , a nie jak myślałem wcześniej z zakładki Account/Integrations/MQTT Broker mqttXX.supla.org.
remote_username i remote_password podawałem już z zakładki Account/Integrations/MQTT Broker i dopiero wtedy ruszyło.